Opened 2 years ago

Closed 2 years ago

#6115 closed defect (invalid)

Compilation in Debian stable/oldstable broken

Reported by: shurreg Owned by:
Priority: important Component: avutil
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: it seems FFmpeg build process is now broken in stock Debian Wheezy and Jessie due to requirement of <stdatomic.h> in libavutil/cpu.c and absense of such a file in gcc 4.7/4.8
How to reproduce (making mplayer with freshly downloaded ffmpeg):

% make
CC	libavutil/cpu.o
libavutil/cpu.c:20:23: fatal error: stdatomic.h: No such file or directory

Change History (2)

comment:1 Changed 2 years ago by cehoyos

  • Keywords regression added
  • Priority changed from minor to important

Isn't this reproducible with FFmpeg compilation?

comment:2 Changed 2 years ago by shurreg

  • Resolution set to invalid
  • Status changed from new to closed

It seems no, it isn't.
So it seems to be mplayer's build system's glitch.

I think I should be sorry for false reporting :)

Note: See TracTickets for help on using tickets.