Opened 6 months ago

Closed 5 months ago

#6116 closed enhancement (fixed)

Please implement VP8 va-api accelerated encoding

Reported by: radek.hvizdos Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: vp8 vaapi
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Patches have landed in libav implementing VP8 va-api accelerated encoding, please implement this in ffmpeg as well: vaapi_encode: Add VP8 support

Thanks

Change History (3)

comment:1 Changed 6 months ago by gjdfgh

It'll be merged sooner or later. Currently, we have a backlog of over 500 commits to merge.

comment:2 Changed 6 months ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords va-api encoding removed
  • Priority changed from normal to wish

comment:3 Changed 5 months ago by jkqxz

  • Resolution set to fixed
  • Status changed from new to closed

d1acab8293054151157910eb081d5edcc7496e13

(Please note that while this is testable with the current Intel driver, it is not yet useful for any real case because the implementation is so terrible. There is a rewrite from Intel pending for the driver here: https://lists.freedesktop.org/archives/libva/2017-January/005078.html ; once this is applied it should be actually-usable.)

Note: See TracTickets for help on using tickets.