Opened 3 months ago

Closed 6 weeks ago

#6030 closed defect (fixed)

assertion failure with -acodec mp3adu

Reported by: ami_stuff Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: crash abort regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

https://trac.ffmpeg.org/raw-attachment/ticket/1958/resample_24000_V_0.mp3

aaa@aaa-VirtualBox /media/sdb1 $ gdb ffmpeg/ffmpeg_g
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ffmpeg/ffmpeg_g...done.
(gdb) r -acodec mp3adu -i resample_24000_V_0.mp3
Starting program: /media/sdb1/ffmpeg/ffmpeg_g -acodec mp3adu -i resample_24000_V_0.mp3
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
ffmpeg version 3.2.git Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 5.3.0 (Ubuntu 5.3.0-3ubuntu1~14.04) 20151204
  configuration: --disable-ffprobe --enable-gpl
  libavutil      55. 35.100 / 55. 35.100
  libavcodec     57. 66.101 / 57. 66.101
  libavformat    57. 57.100 / 57. 57.100
  libavdevice    57.  2.100 / 57.  2.100
  libavfilter     6. 66.100 /  6. 66.100
  libswscale      4.  3.100 /  4.  3.100
  libswresample   2.  4.100 /  2.  4.100
  libpostproc    54.  2.100 / 54.  2.100
[mp3adu @ 0x98d2200] MP3ADU full parser is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
Assertion index > -0x20000000 failed at libavcodec/parser.c:184

Program received signal SIGABRT, Aborted.
0xb7fdccb0 in ?? ()
(gdb) bt
#0  0xb7fdccb0 in ?? ()
#1  0x0916dae0 in ?? ()
#2  0x00000000 in ?? ()
(gdb) 

Change History (3)

comment:1 Changed 3 months ago by cehoyos

  • Keywords crash abort regression added
  • Priority changed from normal to important

comment:2 Changed 6 weeks ago by richardpl

Regression since when?

comment:3 Changed 6 weeks ago by cehoyos

  • Component changed from undetermined to avcodec
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master
Note: See TracTickets for help on using tickets.