Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#6031 closed defect (worksforme)

Hang while converting WTV to MP4

Reported by: kazuna Owned by:
Priority: important Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have a WTV file which causes ffmpeg to hang when converting to MP4.

This is a regression introduced some time around July this year.

Reproduce on FFmpeg (20161210/64-bit/static).
Not Reproduce on FFmpeg (20160619/64-bit/static).

To reproduce, I run a batch file on Windows 10:

:LOOP
ffmpeg -i ABC.WTV -y -s 1280x720 -c:v libx264 -preset veryfast -c:a copy ABC.MP4
GOTO LOOP

It may not reproduce the problem at the first loop but it won't take long.
For me, it reproduces 50% at the first loop and 90% at the second loop.

When it reproduces, I see no interesting console output but it just hangs at a random frame number while counting the frame:

Input stream #0:1 frame changed from size:720x480 fmt:yuv420p to size:1280x720 fmt:yuv420p
Past duration 0.795464 too large
frame=31281 fps=255 q=26.0 size=  217464kB time=00:17:23.40 bitrate=1707.4kbits/s dup=78 drop=31153 speed= 8.5x

Please download the sample WTV file from:
https://www.dropbox.com/s/0w7xs82fxu9tj1t/ABC.WTV?dl=0

Change History (3)

comment:1 Changed 20 months ago by cehoyos

  • Resolution set to worksforme
  • Status changed from new to closed

Works fine here.

If you cannot provide a backtrace (that is needed when reporting a hang), please report the issue on the Zeranoe forum assuming this where you got your binaries from.

comment:2 Changed 20 months ago by kazuna

Yes, I got Windows binary from zeranoe.

Did it work for you on Windows?
If not Windows, then it could be Windows (binary) specific issue?

comment:3 Changed 20 months ago by kazuna

It looks like fixed in the latest build.

Apparently the problem introduced in [x264 20160613-3f5ed56] has just fixed in [x264 20161201-b97ae06].

Note: See TracTickets for help on using tickets.