Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4277 closed enhancement (invalid)

Improve Phantom Cine read support

Reported by: fabian Owned by:
Priority: wish Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

[NB: This is a dup of https://bugzilla.libav.org/show_bug.cgi?id=764]

Dear FFmpeg devs,

some time ago, a feature request was filed against FFmpeg to add read support for the proprietary Phantom Cine video format [1]. Samples have been provided in [2].

However, since then it has become silent around this feature request. As far as I understand, the basic understanding of the file format has been summarized in [3]. This page even links to an extensive documentation [4] of the format provided by its original proprietor, Vision Research Inc.

The copyright notice of this document states the following:
"
The information contained in this document file includes data that is proprietary to Vision
Research, Inc. and shall not be duplicated, used, or disclosed – in whole or in part – for any
purpose other than to create file conversion routines from Vision’s proprietary “CIN” format
to other formats which may be in use by the end user. This restriction does not limit your right
to use information contained in this data if it is obtained from another source without
restriction. The data subject to this restriction are contained in all pages of this file.
"

So, it is allowed to reference the official file format specification for the development of a decoder for this format, which is exactly what I request here.

If you need further video sample material, please do not hesitate to ask for it. I have literally terabytes of videos from a high-speed camera that uses CINE as its native format, i.e. the software that is used to read out the data from the camera uses CINE as its native format. The inly restriction is the file size which is typically in the order of several hundret megabytes, but I can of course provide shorter videos as well if needed.

Thank you very much already!

Best regards,

Fabian

[1] http://ffmpeg.org/pipermail/ffmpeg-devel/2010-March/094865.html
[2] http://samples.mplayerhq.hu/V-codecs/Phantom_Cine/
[3] http://wiki.multimedia.cx/index.php?title=Phantom_Cine
[4] http://www.visionresearch.com/devzonedownloads/cine640.pdf

Change History (6)

comment:1 Changed 3 years ago by cehoyos

Did you consider to test current FFmpeg?

Last edited 3 years ago by cehoyos (previous) (diff)

comment:2 Changed 3 years ago by fabian

  • Priority changed from wish to minor
  • Summary changed from Feature Request: Phantom Cine read support to Improve Phantom Cine read support
  • Version changed from unspecified to 2.5.2

ffplay version 2.5.3-1 is indeed able to open my test file and play a few frames. Unfortunately, it stops after a few frames. It shows the following:

Input #0, cine, from 'al2o3_mod30hz_60perc_xa.cine':= 0B f=0/0

Duration: 00:00:00.27, start: 0.000000, bitrate: N/A

Stream #0:0: Video: rawvideo, gray16le, 960x720, 2600 tbr, 2600 tbn, 2600 tbc
Metadata:

camera_version : 91
firmware_version: 578
software_version: 675
recording_timezone: -7200
brightness : -6
contrast : 0
gamma : 2
wbgain[0].r : 1.000000
wbgain[0].b : 1.000000
shutter_ns : 40000
enable_crop : 1638203607
crop_left : 1319621656
crop_top : 1639852875
crop_right : 1319621656
crop_bottom : 1641506439

Actually, this file is expected to contain about 5000 frames which even in real-time span a time frame of ca. 50 seconds, so the very short duration is somehow "unexpected".

comment:3 Changed 3 years ago by cehoyos

  • Priority changed from minor to wish
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 2.5.2 to git-master

Please test with ffmpeg (the application) and if the issue is reproducible, reopen this ticket and provide your command line, the complete, uncut console output and the sample.

comment:4 Changed 3 years ago by fabian

The issue turned out top be ffplay attempting to play back the video with its actual framerate of 1000/s. This is the reason why it only played for a few seconds. Converting it into an actual video file with a reasonable framerate (e.g. ffmpeg -r 30 -i sample.cine out.mp4) led to the desired result.

comment:5 Changed 3 years ago by cehoyos

Is the framerate of 1000/s correct for the given sample?

comment:6 Changed 3 years ago by fabian

Yes it is, though it's a pain to watch. ;)

Note: See TracTickets for help on using tickets.