Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3290 closed defect (invalid)

libzvbi.h: No such file or directory

Reported by: dinesh547 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

I am trying to build ffmpeg for ios for decoding the dvb_teletext but i am unable to find libzvbi.h is there any way to compile it on ios with --enable--libzvbi flag as there in no such lib or header file in ffmpeg code.

Thanks in advance

Change History (7)

comment:1 Changed 5 years ago by cehoyos

  • Priority changed from important to normal
  • Type changed from sponsoring request to defect

Are you reporting a bug or do you need support?
Please understand that this is a bug tracker, there is a user mailing list for support.

Does configure --enable-libzvbi succeed and make fails? That would indeed be a bug.

comment:2 follow-up: Changed 5 years ago by dinesh547

Seems like a bug to me as configure --enable-libzvbi fails with error libzvbi.h: No such file or directory . I just want to know if i need to use a third party library for compiling using --enable-libzvbi ? but if i remove --enable-libzvbi the code compiles without any issues.

Last edited 5 years ago by dinesh547 (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 5 years ago by cehoyos

  • Component changed from avcodec to undetermined
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 2.1.1 to unspecified

Replying to dinesh547:

Seems like a bug to me as configure --enable-libzvbi fails with error libzvbi.h: No such file or directory .

This is the intended behaviour if you don't have libzvbi (including its header file libzvbi.h) installed on your system.

I just want to know if i need to use a third party library for compiling using --enable-libzvbi ?

Definitely.

but if i remove --enable-libzvbi the code compiles without any issues.

comment:4 follow-up: Changed 5 years ago by dinesh547

are there any steps included in the ffmpeg to build libzvbi for mac or ios?

comment:5 in reply to: ↑ 4 Changed 5 years ago by cehoyos

Replying to dinesh547:

are there any steps included in the ffmpeg to build libzvbi for mac or ios?

No, building external libraries is outside the scope of the FFmpeg project.

Please allow me to repeat that there is a mailing list for user support, this is a bug tracker.

comment:6 Changed 5 years ago by dinesh547

sorry to bother you again, How can i access the mailing list. I am new to this forum.

Last edited 5 years ago by cehoyos (previous) (diff)

comment:7 Changed 5 years ago by cehoyos

Please read http://ffmpeg.org/contact.html
If you think it is too difficult to find this page, please tell us!

Note: See TracTickets for help on using tickets.