Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2501 closed defect (fixed)

FFMPEG subtitles filter segfaults with matroska files

Reported by: klaxa Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: crash SIGSEGV sub
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: FFMPEG crashes when trying to use the videofilter "subtitles" with matroska files that contain subtitle tracks.
How to reproduce: Encode a video with a the "subtitles" videofilter and use a matroska file as the subtitle file argument

% ffmpeg -i input ... outputffmpeg -i hataraku.mkv -c:a libmp3lame -c:v mpeg4 -sn -vf "subtitles=hataraku.mkv" -t 60 hataraku_hardsub.mkv

ffmpeg version N-52453-g12e3c1b Copyright (c) 2000-2013 the FFmpeg developers
  built on Apr 25 2013 00:02:29 with gcc 4.8.0 (GCC)
  configuration: --prefix=/home/klaxa/ffmpeg/build --disable-debug --disable-static --enable-avresample --enable-dxva2 --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-postproc --enable-runtime-cpudetect --enable-shared --enable-vdpau --enable-version3 --enable-x11grab
  libavutil      52. 27.100 / 52. 27.100
  libavcodec     55.  6.100 / 55.  6.100
  libavformat    55.  3.100 / 55.  3.100
  libavdevice    55.  0.100 / 55.  0.100
  libavfilter     3. 60.101 /  3. 60.101
  libavresample   1.  1.  0 /  1.  1.  0
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100


Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

I attached ffmpeg output with high log level, gdb output and valgrind output. Interestingly with valgrind ffmpeg does not segfault, but slowly proceeds to encode and produces the desired result, because of valgrind horribly slow though.

Attachments (3)

hataraku.log (18.0 KB) - added by klaxa 5 years ago.
log with ffmpeg -v 9 -loglevel 99
hataraku.gdb.log (12.7 KB) - added by klaxa 5 years ago.
gdb log with ffmpeg -v 9 -loglevel 99
hataraku.valgrind.log (8.2 KB) - added by klaxa 5 years ago.
valgrind log

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by klaxa

log with ffmpeg -v 9 -loglevel 99

Changed 5 years ago by klaxa

gdb log with ffmpeg -v 9 -loglevel 99

Changed 5 years ago by klaxa

valgrind log

comment:1 Changed 5 years ago by ubitux

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in 035a3792c223d3b2bba79f38049bd6363b2d470d. Thanks for the report.

comment:2 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to avfilter
  • Keywords crash SIGSEGV added; videofilter segmentation fault removed

comment:3 Changed 5 years ago by cehoyos

  • Keywords sub added; subtitles removed
Note: See TracTickets for help on using tickets.