Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2500 closed defect (invalid)

Static libfdk-aac

Reported by: svnpenn Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Normally I can build fdk-aac like this

./configure \

--host i686-w64-mingw32 \
--prefix /usr/i686-w64-mingw32/sys-root/mingw \
--disable-shared

make install

and then build FFmpeg no problem. However I have noticed that if you choose to
build shared, it creates

libfdk-aac-0.dll
libfdk-aac.dll.a

From then on you cannot create an FFmpeg static build with any combination of
configure flags, until you delete these files. Is this by design or some error?

Change History (2)

comment:1 in reply to: ↑ description Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

(Duplicate of ticket #1968)

Replying to svnpenn:

From then on you cannot create an FFmpeg static build with any combination of
configure flags, until you delete these files.

Did you test --extra-ldflags=-static ?

Is this by design or some error?

It is the design of your toolchain (actually every toolchain I know) that it uses dynamic libraries if they are present and nothing else is specified.

comment:2 Changed 5 years ago by svnpenn

Carl, thanks for this. I was sleep deprived and forgot about this fun fact!

Note: See TracTickets for help on using tickets.