Opened 7 months ago

Closed 7 days ago

Last modified 7 days ago

#9653 closed defect (fixed)

mka to mp3 but talk missing

Reported by: Monika Hoffmann Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: opus
Cc: Monika Hoffmann Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
I converted 2 mka into mp3, user1.mp3 is ok, but in user2.mp3 the talk is missing. They alternately count '1 2 3', '4 5 6', ...
The internet connection is bad for User2
How could I use ffmpeg to get a mp3 with talk.
Using MKVToolNix I get a mp3 with talk, so there should be a way
How to reproduce:

% ffmpeg -i "user1.mka" -vn -ab 48k -ar 16000 -ac 2 -c:a libmp3lame "user1.mp3"
% ffmpeg -i "user2.mka" -vn -ab 48k -ar 16000 -ac 2 -c:a libmp3lame "user2.mp3
ffmpeg version 2022-01-24-git-0a83ecbf48-full_build-www.gyan.dev Copyright (c) 2000-2022 the FFmpeg developers
built with gcc 11.2.0 (Rev7, Built by MSYS2 project)

Attachments (5)

user2.mka (400.1 KB ) - added by Monika Hoffmann 7 months ago.
user2.mp3 (339.7 KB ) - added by Monika Hoffmann 7 months ago.
user1.mka (481.6 KB ) - added by Monika Hoffmann 7 months ago.
user1.mp3 (344.7 KB ) - added by Monika Hoffmann 7 months ago.
user2_toolnix.mp3 (406.5 KB ) - added by Monika Hoffmann 7 months ago.
created with mkvtoolnix

Download all attachments as: .zip

Change History (11)

by Monika Hoffmann, 7 months ago

Attachment: user2.mka added

by Monika Hoffmann, 7 months ago

Attachment: user2.mp3 added

by Monika Hoffmann, 7 months ago

Attachment: user1.mka added

by Monika Hoffmann, 7 months ago

Attachment: user1.mp3 added

comment:1 by mkver, 7 months ago

What makes you believe that user2.mka actually contains a talk at all (all I get is something like "one", followed by "ok" a bit later; apart from that, it is just noise)? Or asked differently, what did you do with MKVToolNix to get proper sound with user2.mka?

(And I can assure you that MKVToolNix does not produce a proper mp3 from this input, as MKVToolNix does not contain an opus decoder and an mp3 encoder.)

PS: These files are btw strange: They lack the audio sample rate and channel count fields in the header.

by Monika Hoffmann, 7 months ago

Attachment: user2_toolnix.mp3 added

created with mkvtoolnix

comment:2 by Monika Hoffmann, 7 months ago

I listened to the user2.mka again with "VLC Plus Player".
In the 10th second he speaks for the first time:
"Eins, äh vier fünf sechs"
17th sec: "zehn"
20th sec: "zehn elf zwölf"
28th sec: "sechzehn siebzehn achtzehn"
40th sec: "ok"
47th sec: "ok und jetzt sage ich tschüss, hörst du mich?"
53th sec: "alles klar, tschau"

In MKVToolNix GUI v65.0. - Multiplexer I add user2.mka to the queue and enter user2_toolnix.mp3 to the target, then start Multiplexer
I add the user2_toolnix.mp3

yes, you are right: They lack the audio sample rate and channel count fields in the header.
We get them like this.

My job is to write a program (in javaScript/node) to get an mp3 (or m4a) from mka and then merge them into one file where they talk to each other (together.mp3).
Sometimes also with user1.mkv as together.mp4

Last edited 7 months ago by Monika Hoffmann (previous) (diff)

comment:3 by mkver, 7 months ago

Component: undeterminedavcodec
Keywords: opus added
Reproduced by developer: set
  1. Our native Opus decoder produces garbage with user2.mka; workaround is to use libopus for decoding (use "-c:a libopus -i user2.mka").
  2. MKVToolNix does not produce a real mp3; it produces a Matroska file with Opus audio in it. Using an mp3 extension does not make a proper mp3 out of it.

comment:4 by Monika Hoffmann, 7 months ago

Thank you very much!

comment:5 by mkver, 7 days ago

Resolution: fixed
Status: newclosed

Fixed in e301143f96639b97a8e9a0045f93b56e0f399289. (This makes #9890 basically a duplicate of this ticket.)

comment:6 by Carl Eugen Hoyos, 7 days ago

Priority: importantnormal
Version: unspecifiedgit-master
Note: See TracTickets for help on using tickets.