Opened 4 months ago

Closed 4 months ago

#9439 closed defect (fixed)

videotoolbox DTS is invalid

Reported by: Paul Pacifico Owned by:
Priority: critical Component: undetermined
Version: git-master Keywords: videotoolbox
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description


Summary of the bug:

videotoolbox is not working with the latest git version.

Tested on a Mac M1, h264_videotoolbox and hevc_videotoolbox both show DTS is invalid

How to reproduce:

% ffmpeg -f lavfi -i nullsrc -t 1 -c:v hevc_videotoolbox -s 640x360 -f null -

Using ffmpeg version N-103813-g970264a74f
built on Mac OS Big Sur 11.5.2 with clang 12.0.5

Change History (3)

comment:1 by NoHalfBits, 4 months ago

  • not limited to M1 Macs, fails on Intel too
  • caused by broken assignment to 'vtctx->has_b_frames' in 'vtenc_init' in 'libavcodec/videotoolboxenc.c' in line 1519
  • patch with fix submitted to ffmpeg-devel mailing list on 2021/09/26 with subject '[FFmpeg-devel] [PATCH] avcodec/videotoolboxenc: Fixes non-B-Frame encoding'

comment:2 by Paul Pacifico, 4 months ago

Thanks!

comment:3 by Rick Kern, 4 months ago

Resolution: fixed
Status: newclosed

Fixed in b786bc74

Note: See TracTickets for help on using tickets.