Opened 10 years ago

Closed 10 years ago

#932 closed defect (invalid)

incorrectly displaying video in a QuickTime player with codecs from AVid

Reported by: kuzyag Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: dnxhd
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Reported by kuz...@gmail.com, Today (2 hours ago)
encoded video with into dnxhd codec with -flags +ildct incorrectly displayed in a QuickTime player with codecs from AVid.

top half of picture is normal, bottom half is black.

Attachments (1)

1.jpg (33.5 KB ) - added by kuzyag 10 years ago.
that's how it looks

Download all attachments as: .zip

Change History (9)

by kuzyag, 10 years ago

Attachment: 1.jpg added

that's how it looks

comment:1 by Carl Eugen Hoyos, 10 years ago

Please add the ffmpeg command line you used together with the complete, uncut console output.

in reply to:  1 comment:2 by kuzyag, 10 years ago

Replying to cehoyos:

Please add the ffmpeg command line you used together with the complete, uncut console output.

I convert png image in mov file by using command:

ffmpeg -i test_image_01.png -vcodec dnxhd -b 185M -flags +ildct -an -y test_output.mov

Here the console output:

ffmpeg version N-36363-g0af34c4, Copyright (c) 2000-2012 the FFmpeg developers
  built on Jan  3 2012 02:35:39 with gcc 4.5.0 20100414 (Fedora MinGW 4.5.0-1.fc14)
  configuration: --prefix=/var/www/users/research/ffmpeg/snapshots/build --arch=x86 --target-os=mingw32 --cross-prefix=i686-pc-mingw32- --cc='ccache i686-pc-mingw32-gcc' --enable-w32threads --enable-memalign-hack --enable-runtime-cpudetect --enable-cross-compile --enable-static --disable-shared --extra-libs='-lws2_32 -lwinmm' --extra-cflags='--static -I/var/www/users/research/ffmpeg/snapshots/build/include' --extra-ldflags='-static -L/var/www/users/research/ffmpeg/snapshots/build/lib' --enable-bzlib --enable-zlib --enable-gpl --enable-version3 --enable-nonfree --enable-libx264 --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libfaac --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libmp3lame --enable-libvpx --disable-decoder=libvpx
  libavutil      51. 33.100 / 51. 33.100
  libavcodec     53. 50.100 / 53. 50.100
  libavformat    53. 29.100 / 53. 29.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 57.101 /  2. 57.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  5.100 /  0.  5.100
  libpostproc    51.  2.100 / 51.  2.100
Input #0, image2, from 'test_image_01.png':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: png, bgra, 1920x1080, 25 tbr, 25 tbn, 25 tbc
Please use -b:a or -b:v, -b is ambiguous
Incompatible pixel format 'bgra' for codec 'dnxhd', auto-selecting format 'yuv422p'
[buffer @ 0x1ccf220] w:1920 h:1080 pixfmt:bgra tb:1/1000000 sar:0/1 sws_param:
[buffersink @ 0x176b500] auto-inserting filter 'auto-inserted scale 0' between the filter 'src' and the filter 'out'
[scale @ 0x178d9c0] w:1920 h:1080 fmt:bgra -> w:1920 h:1080 fmt:yuv422p flags:0x4
Output #0, mov, to 'test_output.mov':
  Metadata:
    encoder         : Lavf53.29.100
    Stream #0:0: Video: dnxhd (AVdn / 0x6E645641), yuv422p, 1920x1080, q=2-31, 185000 kb/s, 25 tbn, 25 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (png -> dnxhd)
Press [q] to stop, [?] for help
frame=    1 fps=  0 q=1.0 Lsize=     897kB time=00:00:00.04 bitrate=183678.4kbits/s    

video:896kB audio:0kB global headers:0kB muxing overhead 0.096784%

Input file and encoding result You can find here:
http://downloads.m1stereo.tv/4dafdbb0339b8a4e888401cf89a4b76b/

comment:3 by Carl Eugen Hoyos, 10 years ago

(Does decoding work with FFmpeg?)

Do I understand correctly that it works fine without "-flags +ildct"?
Why are you using the flag?

comment:4 by kuzyag, 10 years ago

because my source is interlaced.

passing +ildct enables interlaced processing, libavcodec/dnxhdenc.c:

[...]
 289     if (avctx->flags & CODEC_FLAG_INTERLACED_DCT) {
 290         ctx->interlaced = 1;
 291         ctx->m.mb_height /= 2;
 292     }
[...]

i will try to check if values from mov_write_avid_tag written correctly...

comment:5 by kuzyag, 10 years ago

This problem appears with Avid QuickTime Codecs LE 2.0 When I update codec to Avid QuickTime Codecs LE 2.1, problem is gone.

comment:6 by Carl Eugen Hoyos, 10 years ago

Keywords: dnxhd added
Version: unspecifiedgit-master

Do you suspect that there is no bug in FFmpeg?

comment:7 by kuzyag, 10 years ago

That's definitely Avid QuickTime? Codecs LE 2.0 bug. It decode DNxHD content generated by Avid QuickTime? Codecs LE 2.1 in the same way as FFmpeg's generated.

comment:8 by Carl Eugen Hoyos, 10 years ago

Resolution: invalid
Status: newclosed

Thank you for testing this!

Note: See TracTickets for help on using tickets.