Opened 11 years ago

Closed 11 years ago

#927 closed enhancement (fixed)

[PATCH] DNxHD: frame multithreading

Reported by: STaRGaZeR Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: patch, DNxHD
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

This patch adds frame multithreading to the DNxHD decoder. Tested and confirmed working on all samples I have, but needs review, since I'm a ffmpeg noob. Results from this sample: http://www.limpans.com/downloads/AVID/DNxHD/NTSC/Swans220X.zip (598 MB)

1 thread: 28 fps
4 threads: 144 fps

Tested on an overclocked i5 2500K (4 cores, 4 threads).

I tried using git send-email but got all kind of errors so I'm posting it here. Hope everything's fine.

Attachments (1)

DNxHD_MT.patch (2.3 KB ) - added by STaRGaZeR 11 years ago.

Download all attachments as: .zip

Change History (2)

by STaRGaZeR, 11 years ago

Attachment: DNxHD_MT.patch added

comment:1 by Michael Niedermayer, 11 years ago

Resolution: fixed
Status: newclosed

Patch applied, thanks

Note: See TracTickets for help on using tickets.