#9226 closed defect (duplicate)

Cannot use any fonts including system fonts

Reported by: Jefferson Villasan Josol Owned by:
Priority: important Component: avfilter
Version: git-master Keywords: Incorrect fonts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg -y -i "/storage/0040-18A0/Music Videos on YouTube/TO be synced/ICSM dance.mkv" -c:s copy -q:s 0 -c:a copy -c:d copy -c:v mpeg2video -q:v 0 -map_metadata 0 -vf "scale=1920:-1,colorspace=all=bt2020,ass=/storage/0040-18A0/Music Videos on YouTube/TO be synced/ICSM dance.ass:fontsdir=/system/fonts/DroidSans.ttf" -bufsize 960M -maxrate 480M -r:v 30 -r:a 30 -t 30 -movflags +write_colr "/storage/0040-18A0/Music Videos on YouTube/TO be synced/30s samples.ts"

Can anyone help me how to use system fonts on ffmpeg Termux? Whatever I try is only giving me DroidSansFallback. Here is another one that ffmpeg says....

[Parsed_ass_2 @ 0xa51dd240] fontselect: ("/system/fonts/DroidSans.ttf", 400, 0) -> /system/fonts/Lohit-Punjabi.ttf, 0, Lohit-Punjabi
[Parsed_ass_2 @ 0xa51dd240] fontselect: (DroidSansChinese, 400, 0) -> /system/fonts/Lohit-Punjabi.ttf, 0, Lohit-Punjabi
[Parsed_ass_2 @ 0xa51dd240] Glyph 0x41 not found, selecting one more font for (DroidSansChinese, 16, 400)
[Parsed_ass_2 @ 0xa51dd240] fontselect: (DroidSansChinese, 400, 0) -> /system/fonts/DroidSansFallback.ttf, 0, DroidSansFallback

Thanks in advance for those who can help me!

Change History (1)

comment:1 by Balling, 13 months ago

Resolution: duplicate
Status: newclosed

Oogh, looks like update to new Trac did not fix the bug in create new ticket button.

Note: See TracTickets for help on using tickets.