Opened 5 months ago

Closed 5 months ago

#9059 closed defect (invalid)

(avisynth/vapoursynth) No progress, no encoding (in some cases) when ffmpeg shared is used (Linux)

Reported by: artenaki Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: avisynth
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It's about Linux. ffmpeg shared 4.3.1 is compiled with --enable-avisynth --enable-vapoursynth --enable-shared --disable-static options. For avisynth and vapoursynth ffms2 and l-smash import plugins are also compiled, they are linked with ffmpeg shared libs. I am creating avs script like:

ffms2("input.mkv")
#LWLibavVideoSource("input.mkv")

Example for vapoursynth:

import vapoursynth as vs
core = vs.get_core()
video = core.ffms2.Source("input.mkv")
#video = core.lsmas.LWLibavSource("input.mkv")
video.set_output()

and open them in ffmpeg (shared) for encoding:

ffmpeg -i input.avs output.mkv
ffmpeg -f vapoursynth -i input.vpy output.mkv

In this case, either nothing happens (white terminal screen), or the encoding is performed, but no information is displayed on the terminal. I think this is because of the recursion. In ffmpeg-static everything works fine and information is displayed. ffmpeg static is compiled with --enable-static --disable-shared options. But ffmpeg-shared normally opens internal scripts like ColorBars ().

At the moment, the situation is as follows:
vapoursynth: ffms2 and l-smash - white screen but encoding is performed
avisynth+: ffms2 - white screen, nothing happens
avisynth+: l-smash - white screen but encoding is performed
You can find out more in these bug reports
https://github.com/AviSynth/AviSynthPlus/issues/194
https://github.com/vapoursynth/vapoursynth/issues/653
And if necessary, talk to the developers of avisynth+ and vapoursynth.
The problem has been confirmed by other people.
Since the problem is observed in different programs: avisynth/vapoursynth and ffms2/lsmash, I suspect that the reason is ffmpeg (shared libs).

Attachments (1)

ffmpeg-logs.7z (91.9 KB ) - added by artenaki 5 months ago.

Download all attachments as: .zip

Change History (5)

by artenaki, 5 months ago

Attachment: ffmpeg-logs.7z added

comment:1 by Carl Eugen Hoyos, 5 months ago

Component: ffmpegundetermined
Keywords: vapoursynth removed

Do you think you tried hard enough to make reading this ticket as difficult as possible?
https://ffmpeg.org/bugreports.html

comment:2 by Carl Eugen Hoyos, 5 months ago

And please test current FFmpeg git head, nothing else is supported here.

comment:3 by artenaki, 5 months ago

Resolution: invalid
Status: newclosed

comment:4 by artenaki, 5 months ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.