Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#898 closed defect (invalid)

-vframes is totally ignored from ffmpeg version N-32355-g4f7dfe1 and above

Reported by: ExSport Owned by:
Priority: important Component: ffmpeg
Version: unspecified Keywords: vframes
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When "-vframes 1" is used, ffmpeg ignores this value and continues to the end of file.
This bug is introduced from version N-32355-g4f7dfe1 but this one works well: N-32290-g6fc1299
Command what I used:
ffmpeg.exe -vframes 1 -i Test.mkv -v codec copy -f h264 -vbsf h264_mp4toannexb -an -y output.ts

Many thanks for fix!
ExSport?

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Move -vframes 1 behind Test.mkv (vframes is an option you want to apply to the output file, imagine you are encoding several files at once, you may use different vframes options, that did not work with the syntax you are still using).

comment:2 Changed 5 years ago by ExSport

Thanks for useful info, it works!:-)
Sorry to post it as bug because it worked and stopped working with new versions but I didn't found any info that vframes should be used after -i "filename"
Thanks again!

Note: See TracTickets for help on using tickets.