Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#8933 closed defect (needs_more_info)

http m3u8 download command stopped working in 4.3

Reported by: aaaeeeo Owned by:
Priority: normal Component: ffmpeg
Version: git-master Keywords:
Cc: liuqi05@kuaishou.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

ffmpeg -protocol_whitelist file,http,https,tcp,tls,crypto -i https://.../xxx.mp4/playlist.m3u8 -c copy -bsf:a aac_adtstoasc "test.mp4"
4.3.1
built on mac

Got following error:
[https @ 0x7fcb5c813200] Opening 'https://.../xxx.mp4/chunklist_w1708679321.m3u8' for reading
[hls @ 0x7fcb5d00ac00] Failed to reload playlist 0

The same command works good on 4.2.3 and 4.2

Attachments (3)

ffmpeg-4.3.1.log (12.5 KB ) - added by aaaeeeo 13 months ago.
ffmpeg-4.2.log (18.5 KB ) - added by aaaeeeo 13 months ago.
ffmpeg-20201013-184200.log (618.2 KB ) - added by Steven Liu 13 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 by Steven Liu, 13 months ago

Resolution: worksforme
Status: newclosed

I cannot guess what happened base on your computer.

(base) liuqi05:clang liuqi$ ./ffmpeg -i https://devstreaming-cdn.apple.com/videos/streaming/examples/img_bipbop_adv_example_ts/v2/prog_index.m3u8 -c copy -t 10 -y out.ts
ffmpeg version git-2020-10-12-54d178fc69 Copyright (c) 2000-2020 the FFmpeg developers
  built with Apple clang version 12.0.0 (clang-1200.0.32.2)
  configuration: --cc=clang --quiet --enable-htmlpages --enable-libx264 --enable-libxml2 --enable-gpl --extra-ldflags='-O0 -g3 -fsanitize=address -Wno-error -fPIC -I/usr/local/include' --extra-ldflags='-O0 -g3 -fsanitize=address -Wno-error -fPIC -L/usr/local/lib' --enable-libfreetype --enable-fontconfig --enable-libspeex --enable-libopus --enable-libzmq --enable-libx265 --enable-libass --enable-videotoolbox --disable-optimizations --enable-audiotoolbox --enable-opengl --disable-stripping --samples=fate-suite/
  libavutil      56. 59.100 / 56. 59.100
  libavcodec     58.106.100 / 58.106.100
  libavformat    58. 58.100 / 58. 58.100
  libavdevice    58. 11.102 / 58. 11.102
  libavfilter     7. 87.100 /  7. 87.100
  libswscale      5.  8.100 /  5.  8.100
  libswresample   3.  8.100 /  3.  8.100
  libpostproc    55.  8.100 / 55.  8.100
[hls @ 0x61b000000780] Skip ('#EXT-X-VERSION:3')
[hls @ 0x61b000000780] Skip ('#EXT-X-INDEPENDENT-SEGMENTS')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:377')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:385')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:388')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:372')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:374')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:372')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:371')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:384')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:384')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:370')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:374')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:373')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
    Last message repeated 2 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:381')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:372')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:376')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:375')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:371')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:380')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:371')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:377')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:375')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:381')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:375')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:374')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:380')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:385')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
    Last message repeated 2 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:372')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:373')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:376')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:375')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:377')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:373')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:371')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:384')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:376')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:383')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:377')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:374')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:377')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
    Last message repeated 3 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:374')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:375')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:386')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:390')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:381')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:385')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:383')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:379')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:383')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:387')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:386')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:381')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:378')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:382')
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:381')
    Last message repeated 1 times
[hls @ 0x61b000000780] Skip ('#EXT-X-BITRATE:383')
[hls @ 0x61b000000780] Opening 'https://devstreaming-cdn.apple.com/videos/streaming/examples/img_bipbop_adv_example_ts/v2/fileSequence0.ts' for reading
[hls @ 0x61b000000780] Opening 'https://devstreaming-cdn.apple.com/videos/streaming/examples/img_bipbop_adv_example_ts/v2/fileSequence1.ts' for reading
Input #0, hls, from 'https://devstreaming-cdn.apple.com/videos/streaming/examples/img_bipbop_adv_example_ts/v2/prog_index.m3u8':
  Duration: 00:10:00.00, start: 10.033333, bitrate: 0 kb/s
  Program 0
    Metadata:
      variant_bitrate : 0
    Stream #0:0: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 480x270 [SAR 1:1 DAR 16:9], Closed Captions, 30 fps, 30 tbr, 90k tbn, 60 tbc
    Metadata:
      variant_bitrate : 0
Output #0, mpegts, to 'out.ts':
  Metadata:
    encoder         : Lavf58.58.100
    Stream #0:0: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 480x270 [SAR 1:1 DAR 16:9], q=2-31, 30 fps, 30 tbr, 90k tbn, 90k tbc
    Metadata:
      variant_bitrate : 0
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
Press [q] to stop, [?] for help
[https @ 0x626000003100] Opening 'https://devstreaming-cdn.apple.com/videos/streaming/examples/img_bipbop_adv_example_ts/v2/fileSequence2.ts' for reading
frame=  301 fps=0.0 q=-1.0 Lsize=     539kB time=00:00:09.96 bitrate= 442.9kbits/s speed=97.2x
video:454kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 18.645016%
(base) liuqi05:clang liuqi$

by aaaeeeo, 13 months ago

Attachment: ffmpeg-4.3.1.log added

by aaaeeeo, 13 months ago

Attachment: ffmpeg-4.2.log added

comment:2 by aaaeeeo, 13 months ago

Resolution: worksforme
Status: closedreopened

Okay, I have attached two report logs.

The exact same command worked on 4.2 and failed on 4.3.1
I'm using binaries for mac downloaded from https://evermeet.cx/pub/ffmpeg/

comment:3 by aaaeeeo, 13 months ago

Version: unspecifiedgit-master

in reply to:  2 ; comment:4 by Steven Liu, 13 months ago

Resolution: needs_more_info
Status: reopenedclosed

Replying to aaaeeeo:

Okay, I have attached two report logs.

The exact same command worked on 4.2 and failed on 4.3.1
I'm using binaries for mac downloaded from https://evermeet.cx/pub/ffmpeg/

https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
what's this context? or can you leave a usable url here? let me analyze about that.

(base) liuqi05:clang liuqi$ curl https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/chunklist_w1894645484.m3u8
curl: (7) Failed to connect to stream.bwnvideo.com port 443: No route to host
(base) liuqi05:clang liuqi$ curl https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to stream.bwnvideo.com:443
(base) liuqi05:clang liuqi$ curl https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to stream.bwnvideo.com:443
(base) liuqi05:clang liuqi$ wget https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
--2020-10-13 18:16:00--  https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
正在解析主机 stream.bwnvideo.com (stream.bwnvideo.com)... 104.21.235.173, 104.21.235.174
正在连接 stream.bwnvideo.com (stream.bwnvideo.com)|104.21.235.173|:443... 失败:No route to host。
正在连接 stream.bwnvideo.com (stream.bwnvideo.com)|104.21.235.174|:443... 失败:Operation timed out。
重试中。

--2020-10-13 18:17:20--  (尝试次数: 2)  https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
正在连接 stream.bwnvideo.com (stream.bwnvideo.com)|104.21.235.173|:443... 已连接。
无法建立 SSL 连接。
(base) liuqi05:clang liuqi$

in reply to:  4 comment:5 by aaaeeeo, 13 months ago

The content of playlist.m3u8 is

#EXTM3U
#EXT-X-VERSION:3
#EXT-X-STREAM-INF:BANDWIDTH=1635957,CODECS="avc1.4d401e,mp4a.40.2",RESOLUTION=640x360
chunklist_wxxx.m3u8

And the content of chunklist_wxxx.m3u8 is

#EXTM3U
#EXT-X-VERSION:3
#EXT-X-TARGETDURATION:5
#EXT-X-MEDIA-SEQUENCE:0
#EXTINF:4.004,
media_wxxx_0.ts
#EXTINF:4.004,
media_wxxx_1.ts
#EXTINF:4.004,
media_wxxx_2.ts
#EXTINF:4.004,

...

#EXT-X-ENDLIST

Not sure why 4.3 refused to open the second m3u8

Replying to stevenliu:

Replying to aaaeeeo:

Okay, I have attached two report logs.

The exact same command worked on 4.2 and failed on 4.3.1
I'm using binaries for mac downloaded from https://evermeet.cx/pub/ffmpeg/

https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
what's this context? or can you leave a usable url here? let me analyze about that.

(base) liuqi05:clang liuqi$ curl https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/chunklist_w1894645484.m3u8
curl: (7) Failed to connect to stream.bwnvideo.com port 443: No route to host
(base) liuqi05:clang liuqi$ curl https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to stream.bwnvideo.com:443
(base) liuqi05:clang liuqi$ curl https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to stream.bwnvideo.com:443
(base) liuqi05:clang liuqi$ wget https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
--2020-10-13 18:16:00--  https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
正在解析主机 stream.bwnvideo.com (stream.bwnvideo.com)... 104.21.235.173, 104.21.235.174
正在连接 stream.bwnvideo.com (stream.bwnvideo.com)|104.21.235.173|:443... 失败:No route to host。
正在连接 stream.bwnvideo.com (stream.bwnvideo.com)|104.21.235.174|:443... 失败:Operation timed out。
重试中。

--2020-10-13 18:17:20--  (尝试次数: 2)  https://stream.bwnvideo.com/vod/_definst_/mp4:bwnvideos/videos/x15_FFB.mp4/playlist.m3u8
正在连接 stream.bwnvideo.com (stream.bwnvideo.com)|104.21.235.173|:443... 已连接。
无法建立 SSL 连接。
(base) liuqi05:clang liuqi$

comment:6 by Steven Liu, 13 months ago

cannot reproduce it :-(

my log atteched

by Steven Liu, 13 months ago

Attachment: ffmpeg-20201013-184200.log added

comment:7 by Steven Liu, 13 months ago

Cc: liuqi05@kuaishou.com added
Note: See TracTickets for help on using tickets.