Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#887 closed defect (fixed)

Assertion error in swresample.c

Reported by: oanastratulat Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: aac abort crash
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

The file supplied has too many channels 22. The max number of allowed channels is 16.

Attachments (4)

crash.mp4 (55.3 KB) - added by oanastratulat 5 years ago.
use this file to reproduce the crash
valgrind (3.1 KB) - added by oanastratulat 5 years ago.
valgrind report
0001-Patch-for-assertion-error-in-swresample.c.-Fiexes-bu.patch (1.1 KB) - added by oanastratulat 5 years ago.
Patch for this bug.
0001-Patch-for-assertion-error-in-swresample.c.-Fiexes-bu.2.patch (1.4 KB) - added by oanastratulat 5 years ago.
Patch for this bug.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by oanastratulat

use this file to reproduce the crash

Changed 5 years ago by oanastratulat

valgrind report

Changed 5 years ago by oanastratulat

Patch for this bug.

Changed 5 years ago by oanastratulat

Patch for this bug.

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords aac added
  • Reproduced by developer set
  • Status changed from new to open

Regression since 810a14d

Is this a valid sample or was it produced with zzuf or similar?

comment:2 Changed 5 years ago by oanastratulat

it is produced with zzuf.

comment:3 Changed 5 years ago by ubitux

Patch message edited, "inputput" typo fixed, and pushed. Thanks.

I'm not closing the issue since Michael might want to comment on the regression.

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Since the file was intentionally broken, I don't think decoding is necessary.

comment:5 Changed 4 years ago by cehoyos

  • Keywords abort added

comment:6 Changed 4 years ago by cehoyos

  • Keywords crash added
Note: See TracTickets for help on using tickets.