Opened 16 months ago

Closed 3 months ago

Last modified 3 months ago

#8822 closed enhancement (fixed)

Update Trac to 1.4

Reported by: necros Owned by:
Priority: wish Component: trac
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

subj

Change History (6)

comment:1 by Carl Eugen Hoyos, 10 months ago

Keywords: update removed
Priority: normalwish

comment:2 by Balling, 10 months ago

Maybe it will fix checking for button send double press, I like the idea.

comment:3 by Balling, 8 months ago

Resolution: fixed
Status: newclosed

Fixed, yeah! To 1.4.2 actually.

Last edited 8 months ago by Balling (previous) (diff)

comment:4 by Balling, 3 months ago

Resolution: fixed
Status: closedreopened

You did not update static resourses of trac properly (since double submission was fixed, yet it is still a problem here).

See my trac-users help request here and their answer: https://groups.google.com/g/trac-users/c/ZRhstKKKn2o/m/ybOVkpC9HQAJ?utm_medium=email&utm_source=footer&pli=1

The bug with Javascript not disabling a button was fixed long time ago: https://trac.edgewall.org/ticket/10138

Yet without updating static resourses this will not be fixed: https://trac.edgewall.org/wiki/TracUpgrade#a6.Refreshstaticresources

You just need to do

$ trac-admin /path/to/env deploy /deploy/path

Just press F12 in chrome and you will see in console

Failed to load resource: the server responded with a status of 404 (Not Found)

and

Uncaught TypeError: $(...).disableSubmit is not a function

Last edited 3 months ago by Balling (previous) (diff)

comment:5 by Elon Musk, 3 months ago

Resolution: fixed
Status: reopenedclosed

comment:6 by Balling, 3 months ago

Just checked, F12 warnings still happen. There may be all kind of vulns there, so I recommend you update it.

Note: See TracTickets for help on using tickets.