Opened 2 years ago

Closed 21 months ago

#8797 closed defect (invalid)

Audio container is not changed in the latest version ffmpeg duing webm to .ts conversion

Reported by: Jothimani Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Audio container is not changed while converting from .webm to .ts in the version (4.3.1) however working well in (4.1.3)

How to reproduce:
Command: ffmpeg -y -i input.webm -c copy -copyts -muxdelay 0 -muxpreload 0 -c:a:v libmp3lame -crf 0 out.ts

working in ffmpeg version:
ffmpeg version 4.1.3 Copyright (c) 2000-2019 the FFmpeg developers

built with Apple LLVM version 10.0.1 (clang-1001.0.46.4)

NOT working in this version:
ffmpeg version 4.3.1-tessus https://evermeet.cx/ffmpeg/ Copyright (c) 2000-2020 the FFmpeg developers

built with Apple clang version 11.0.0 (clang-1100.0.33.17)

Change History (2)

comment:1 by Carl Eugen Hoyos, 2 years ago

Component: ffmpegundetermined
Keywords: ffmpeg audio codec removed
Version: 4.2unspecified

Please test current FFmpeg git head, the only version supported on this bug tracker, and provide the command line you tested together with the complete, uncut console output to make this a valid ticket.

comment:2 by mkver, 21 months ago

Resolution: invalid
Status: newclosed

"-c:a:v libmp3lame": That's an invalid stream specifier that is no longer accepted since dbfd042983eed8586d4048795c00af820f5b6b1f.

Note: See TracTickets for help on using tickets.