Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#852 closed defect (fixed)

MTS files from Canon HG20 no longer replayed

Reported by: stef716 Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: h264 seek
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Hi,

MTS videos produced by my AVCHD camcorder are no longer properly replayed by ffmpeg and ffmpeg based video players.

  • vlc player just shows a black image.
  • xine and gxine play from the beginning but freezes after frame jump
  • ffplay 00017.MTS plays from the beginning but seeking in file (ffplay 00017.MTS -ss 1) shows no image
  • video editing with kdenlive renders partly black video sequences

Latest working version I went back was 0.8.7.
Version 0.9 from Debian Multimedia AMD64 and also the git-master I just compiled today have this issue.

The problem was confirmed by more users on the Debian Multimedia mailing list for i386 and AMD64.

Change History (10)

comment:1 Changed 5 years ago by stef716

comment:2 Changed 5 years ago by cehoyos

Failing ffmpeg command line and complete, uncut console output missing.

comment:3 Changed 5 years ago by stef716

command: ffplay -ss 2 00017.MTS

ffplay version 0.9, Copyright (c) 2003-2011 the FFmpeg developers

built on Dec 29 2011 23:52:31 with gcc 4.6.2
configuration: --prefix=/usr --extra-cflags='-Wall -g ' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-nonfree --enable-libdirac --disable-decoder=libdirac --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-libvpx --enable-librtmp --enable-avfilter --enable-frei0r --enable-libopencv --enable-libfreetype --enable-libvo-aacenc --disable-decoder=amrnb --enable-libvo-amrwbenc --enable-libaacplus --libdir=/usr/lib/x86_64-linux-gnu --disable-vda --enable-libdc1394 --disable-altivec --disable-armv5te --disable-armv6 --disable-vis --shlibdir=/usr/lib/x86_64-linux-gnu
libavutil 51. 33.100 / 51. 33.100
libavcodec 53. 49.100 / 53. 49.100
libavformat 53. 29.100 / 53. 29.100
libavdevice 53. 4.100 / 53. 4.100
libavfilter 2. 55.100 / 2. 55.100
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 5.100 / 0. 5.100
libpostproc 51. 2.100 / 51. 2.100

[h264 @ 0x2456960] Increasing reorder buffer to 1
Input #0, mpegts, from '/home/stef/download/00017.MTS':

Duration: 00:00:14.40, start: 0.484122, bitrate: 23361 kb/s
Program 1

Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 50 tbc
Stream #0:1[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, s16, 256 kb/s

[h264 @ 0x2456960] Missing reference pictureKB vq= 3574KB sq= 0B f=0/0
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] Missing reference picture
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] Missing reference picture
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] Missing reference picture
[h264 @ 0x2456960] QP 53 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 53 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] Reference 3 >= 2
[h264 @ 0x2456960] error while decoding MB 6 0, bytestream (116504)
[h264 @ 0x2456960] Reference 3 >= 2
[h264 @ 0x2456960] error while decoding MB 12 1, bytestream (113484)
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 53 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 53 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] Reference 5 >= 2
[h264 @ 0x2456960] error while decoding MB 71 3, bytestream (118690)
[h264 @ 0x2456960] QP 53 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
[h264 @ 0x2456960] QP 54 out of range
[h264 @ 0x2456960] decode_slice_header error
C 4.89 A-V:-1325199385.125 fd= 0 aq= 225KB vq=15137KB sq= 0B f=0/0

comment:4 Changed 5 years ago by cehoyos

Is the problem not reproducible with ffmpeg?
Please only report problems for ffplay if they are unreproducible with ffmpeg (and mention that you tested ffmpeg).

comment:5 follow-up: Changed 5 years ago by stef716

@cehoyos:
Sorry, but I don't understand what information you are requesting.

There is some issue in the av-libs not to perform seeking in the videos from my camcorder any more. It's reproducable with all applications linking libav, even with ffplay included in ffmpeg package.

These videos have been working with ffmpeg since 3 years. So some usecase seems to be broken starting from version 0.9.

I'm no expert in your libraries but my rough guess is that seeking in videos which do not contain a single I-Frame (like from my camcorder) is no longer possible.

Please just download the video in the link, seek in the video and you will see the issue.

comment:6 in reply to: ↑ 5 Changed 5 years ago by cehoyos

Replying to stef716:

There is some issue in the av-libs not to perform seeking in the videos from my camcorder any more. It's reproducable with all applications linking libav, even with ffplay included in ffmpeg package.

Note that it works fine with MPlayer (and ffmpeg -ss 7 -i 00017.MTS -qscale 2 out.avi).

comment:7 Changed 5 years ago by cehoyos

The problem you see is related to an often requested feature: "Please do not show artefacts after seeking in H264 streams!"
The fix for mentioned problem introduces problems for some streams, see http://article.gmane.org/gmane.comp.video.mplayer.cvs/18456/match=34249 for how MPlayer disabled the new feature.
(Set CODEC_FLAG2_SHOW_ALL)

comment:8 Changed 5 years ago by michael

  • Component changed from undetermined to avcodec
  • Keywords h264 random access added
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Locally fixed, will be in git master soon

comment:9 Changed 5 years ago by cehoyos

Fixed in upcoming 0.9.1, you can test with git checkout release/0.9

comment:10 Changed 4 years ago by cehoyos

  • Keywords seek added; random access removed
Note: See TracTickets for help on using tickets.