Opened 3 years ago

Closed 3 years ago

#8507 closed defect (invalid)

ffmpeg hls output big ts file

Reported by: lempa Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
ffmpeg hls input hls output file grow to gigabyte.;;
How to reproduce:

start 1st ffmpeg which you can kill and restart:

%ffmpeg -i any_hls_or_udp_source -vcodec copy -acodec copy -sn -map_metadata 0 -f hls -hls_flags delete_segments -hls_time 10 -hls_list_size 6 -hls_segment_type mpegts -start_number $(echo $(CMD=`grep -s EXT-X-MEDIA-SEQUENCE stream.m3u8`; if [[ ! -z $CMD ]]; then echo $CMD|awk -F ':' '{print $2}'; else echo 100;fi)) -hls_start_number_source epoch -hls_segment_filename "file%07d.ts" stream.m3u8

start 2nd ffmpeg 
% ffmpeg -err_detect ignore_err  -i http://localhost/ffmpeg/stream.m3u8 -vcodec copy -acodec copy -sn -map_metadata 0 -f hls -hls_flags delete_segments -hls_time 10 -hls_list_size 6 -hls_segment_type mpegts -hls_segment_filename "file%07d.ts" stream.m3u8ffmpeg version

ffmpeg version 4.2.2-static

start 1st ffmpeg, start 2nd ffmpeg after it creates 2 files kill 1st and start again. 2nd ffmpeg will grow last ts file to gigabytes

Change History (3)

comment:1 by Carl Eugen Hoyos, 3 years ago

Version: unspecified

Please test current FFmpeg git head and provide the command line you tested together with the complete, uncut console output to make this a valid ticket and please explain why you believe the behaviour you see is buggy.

comment:2 by lempa, 3 years ago

looks like build 20200130 works and also doesnt have byte range error.

comment:3 by Carl Eugen Hoyos, 3 years ago

Resolution: invalid
Status: newclosed

Thank you for further testing.

Note: See TracTickets for help on using tickets.