Opened 3 years ago

Closed 10 months ago

Last modified 10 months ago

#8367 closed defect (wontfix)

drawgraph documentation

Reported by: Michael Koch Owned by: Gyan
Priority: minor Component: documentation
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Please replace the sentence
"The color is defined as 0xAABBGGRR."
by
"The foreground colors are defined as 0xAABBGGRR and the background color is defined as 0xRRGGBBAA. Please note that FFmpeg's predefined colors are 0xRRGGBBAA and can't be used for the foreground colors."

Change History (13)

comment:1 by Michael Koch, 3 years ago

Here is an example for reproducing the problem. Both colors are defined as 0xffff0000. For the foreground this is blue and for the background this is yellow. If it's not wanted to correct this bug in the code (because of backward compatibility), then it should at least be described correctly in the documentation.

ffmpeg -f lavfi -i testsrc2=size=vga:duration=10 -lavfi "signalstats,drawgraph=m1=lavfi.signalstats.YAVG:size=vga:min=0:max=255:fg1=0xffff0000:bg=0xffff0000[1];[0][1]hstack" -y out.mp4

comment:2 by Gyan, 3 years ago

Owner: set to Gyan
Priority: normalminor
Status: newopen

Will confirm and update. Thanks.

comment:3 by Elon Musk, 10 months ago

Resolution: needs_more_info
Status: openclosed

comment:4 by Michael Koch, 10 months ago

Resolution: needs_more_info
Status: closedreopened

This ticket doesn't need more info. The problem is clearly described and a possible solution was already suggested.

comment:5 by Elon Musk, 10 months ago

Resolution: wontfix
Status: reopenedclosed

comment:6 by Michael Koch, 10 months ago

You are actively working against better documentation.

comment:7 by Elon Musk, 10 months ago

Nope, if you want to improve send patches. Spamming this trac with docs request for changes is considered as hurting project and taking up resources.

comment:8 by Michael Koch, 10 months ago

Is it a general consensus that tickets are considered as spam, if they are about improvements of the documentation and don't include a patch?

The documentation of the drawgraph filter contains the sentence
"The color is defined as 0xAABBGGRR". This is wrong or at least incomplete.
The foreground colors are defined as 0xAABBGGRR but the background color is defined as 0xRRGGBBAA.

comment:9 by Nicolas George, 10 months ago

I am not aware of any such of any such consensus.

Also, I find rather childish the Trac user formerly known as “richardpl” changing their name that of a famous person.

OTOH, if part of a filter behaves differently from both the documentation and the rest of the filter, then the bug is in the filter, not the documentation. Have you tried submitting a patch to make the working of the filter consistent?

in reply to:  9 ; comment:10 by Michael Koch, 10 months ago

Replying to Nicolas George:

OTOH, if part of a filter behaves differently from both the documentation and the rest of the filter, then the bug is in the filter, not the documentation. Have you tried submitting a patch to make the working of the filter consistent?

That's exactly what I suggested some time ago, but it was rejected:
http://ffmpeg.org/pipermail/ffmpeg-user/2019-November/045899.html

in reply to:  10 comment:11 by Nicolas George, 10 months ago

No decision can be taken on the -users mailing-list. I really suggest you submit a patch to fix the issue.

comment:12 by Michael Koch, 10 months ago

I can't make this patch myself and I'm not familiar with git.

comment:13 by Nicolas George, 10 months ago

Then get familiar, because obviously nobody cares enough to do it for you.

Note: See TracTickets for help on using tickets.