Opened 5 years ago

Closed 5 years ago

#835 closed defect (invalid)

edge defects to play wmv7/8/9 or vc1 files on beagleboard

Reported by: kaijun61 Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: wmv arm
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When I play wmv7/8/9 or vc1 files on cortex-a8 based beagleboard with recent ffmpeg based gstreamer, there are random green color at the top edge of screen and mirrored image at the left edge of screen. But no problem to play h264, mpeg4/2/1 files

Change History (20)

comment:1 Changed 5 years ago by cehoyos

  • Keywords changed from wmv, arm to wmv arm

Is this also reproducible with the following?
ffmpeg -i input -an -qscale 2 out.avi
If yes,. please provide complete, uncut console output and please also test with --disable-asm (and report).

Do you think this is a regression?

comment:2 Changed 5 years ago by kaijun61

Hi, after ffmpeg conversion, the defects are gone. I don't think it is a regression.

comment:3 Changed 5 years ago by cehoyos

  • Priority changed from important to normal

I meant: Is the problem is reproducible if you install current ffmpeg on your beagleboard and try above command line (on the beagleboard) - does the output file show the artefacts you saw at playback?

comment:4 Changed 5 years ago by kaijun61

After I converted wmv9 into mpeg4 on beagleboard by ffmpeg as suggested, then I see no artifacts at playback.

comment:5 Changed 5 years ago by cehoyos

Then why do you think there is an issue?

comment:6 Changed 5 years ago by kaijun61

As explained, if I play the original wmv9 file, there are artifacts at the edges of screen. But after it is converted into mpeg4 file as suggested, then I play the mpeg4 file. Those artifacts disappear!

comment:7 Changed 5 years ago by cehoyos

Can you reproduce the artefacts if you compile FFmpeg with --disable-asm?

comment:8 Changed 5 years ago by kaijun61

No, not reproduceable. Those artefacts disappear in the mpeg4 after I compile FFmpeg with --disable-asm.

comment:9 Changed 5 years ago by cehoyos

I thought the artefacts are only visible with WMV, not with mpeg4?

comment:10 Changed 5 years ago by kaijun61

yes, that is issue.

comment:11 Changed 5 years ago by cehoyos

So if you see artefacts playing a wmv9 file, do you also see the artefacts if you compile libavcodec (FFmpeg) with --disable-asm?

comment:12 Changed 5 years ago by kaijun61

yes, I do. It seems wmv9 doesn't use neon.

Last edited 5 years ago by kaijun61 (previous) (diff)

comment:13 Changed 5 years ago by cehoyos

Is the problem also reproducible on other platforms?

comment:14 Changed 5 years ago by kaijun61

I cannot see them in PC.

comment:15 Changed 5 years ago by cehoyos

Do you suspect a compiler issue?

comment:16 Changed 5 years ago by kaijun61

Why?

comment:17 Changed 5 years ago by cehoyos

If the same code works fine on one platform but not on another (and you disabled all platform-specific optimisations), what other reason for the failure is likely?

Could you explain how you are compiling current GStreamer with current FFmpeg? Perhaps I can try to reproduce the issue...

comment:18 Changed 5 years ago by kaijun61

all are compiled with OE (angstrom tool chains).

comment:19 Changed 5 years ago by kaijun61

I sorted out the issue. It is my bug. Since the decoded frame buffers are allocated in physical contiguous memory for post-processing by DSP, h264, mpeg2/4 increase decoded frame size for CODEC_FLAG_EMU_EDGE, but wmv9 doesn't. That is why I see artefacts of edges.

comment:20 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.