Opened 5 years ago

Closed 5 years ago

#826 closed defect (wontfix)

Missing ff_cropTbl symbol needed by MLT

Reported by: marillat Owned by:
Priority: normal Component: avcodec
Version: 0.9 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

MLT use ff_cropTbl() (removed in ffmpeg 0.9) in src/modules/avformat/filter_avdeinterlace.c

http://mltframework.org/gitweb/mlt.git?p=mltframework.org/mlt.git;a=blob;f=src/modules/avformat/filter_avdeinterlace.c;h=b75117453652b3e0427c7435b4452204f7773008;hb=HEAD#l139

Also #include <asm/types.h> is really needed in libavdevice/v4l2.c ?

This include break the build for non Linux arches like kfreebsd and v4l2.c build fine without this include in Linux or Kfreebsd.

Christian

Change History (7)

comment:1 in reply to: ↑ description ; follow-up: Changed 5 years ago by cehoyos

Replying to marillat:

Also #include <asm/types.h> is really needed in libavdevice/v4l2.c ?

This include break the build for non Linux arches like kfreebsd

Could you elavborate?
This seems to be checked in configure.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by marillat

Replying to cehoyos:

Replying to marillat:

Also #include <asm/types.h> is really needed in libavdevice/v4l2.c ?

This include break the build for non Linux arches like kfreebsd

Could you elavborate?

Befare, this bug report contains two bug reports.

This seems to be checked in configure.

grep asm/types.h configure return nothing.

In libavdevice/v4l2.c asm/types.h is always included if v4l2 is enabled or detected. This doesn't work for kfreebsd who doesn't have asm/types.h

Christian

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by cehoyos

Replying to marillat:

Replying to cehoyos:

Replying to marillat:

Also #include <asm/types.h> is really needed in libavdevice/v4l2.c ?

This include break the build for non Linux arches like kfreebsd

Could you elavborate?

Befare, this bug report contains two bug reports.

Yes, but I don't think you'll like my opinion about the other problem...
;-)

This seems to be checked in configure.

grep asm/types.h configure return nothing.

Sorry, I looked into master where this was fixed.
If nobody beats me, I'll try to backport next week.

Merry Christmas, Carl Eugen

comment:4 in reply to: ↑ 3 Changed 5 years ago by marillat

Replying to cehoyos:

Replying to marillat:

Replying to cehoyos:

Replying to marillat:

Also #include <asm/types.h> is really needed in libavdevice/v4l2.c ?

This include break the build for non Linux arches like kfreebsd

Could you elavborate?

Befare, this bug report contains two bug reports.

Yes, but I don't think you'll like my opinion about the other problem...
;-)

I see what you mean ;-)

But what to do with programs who use ffmpeg private symbols ?

Most of the times these programs also use an internal ffmpeg version and use private symbol. I already did a bug report for a similar problem with XBMC (see #762).

Merry Christmas, Christian

comment:5 Changed 5 years ago by reimar

You can just add those symbols to the list of symbols that should be exported.
However this case is more problematic than just using a private symbol: This array is only initialized when dsputils are initialized, which the application has no control over at all which will cause issues even with their own FFmpeg copy.
This is likely to cause serious and hard to debug issues, like the deinterlace filter breaking completely when using it on a raw uncompressed video but working fine when playing a H.264 file.
The array is trivial, so except for wasting some memory it should be a problem for the program to have its own copy of it.

comment:6 in reply to: ↑ description Changed 5 years ago by cehoyos

Replying to marillat:

Also #include <asm/types.h> is really needed in libavdevice/v4l2.c ?

This include break the build for non Linux arches like kfreebsd and v4l2.c build fine without this include in Linux or Kfreebsd.

This should be fixed in all future 0.9 releases (you can test with git checkout release/0.9).

For the future, please try to open one issue per ticket.

Thank you for the report, Carl Eugen

comment:7 Changed 5 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

I don't think we should export ff_cropTbl().

Note: See TracTickets for help on using tickets.