Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#8212 closed defect (invalid)

Add a new HDV1080 format

Reported by: Samuel Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the wish:
HDV-HD format is not available yet.
https://en.m.wikipedia.org/wiki/HDV

How to reproduce:

% ffmpeg -i input -f hdv1080 output

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (18)

comment:1 by Carl Eugen Hoyos, 2 years ago

Component: avformatundetermined
Keywords: hdv removed
Resolution: invalid
Status: newclosed

comment:2 by Samuel, 2 years ago

Component: undeterminedavformat
Keywords: hdv added
Resolution: invalid
Status: closedreopened

comment:3 by Elon Musk, 2 years ago

Resolution: invalid
Status: reopenedclosed

comment:4 by Samuel, 2 years ago

Maybe this is an invalid wish, if you could explain why.

comment:5 by Elon Musk, 2 years ago

No samples provided.

comment:6 by Samuel, 2 years ago

Oh...​sorry for having missed that it was need in that case :(

http://www.spirton.com/uploads/FFmpeg/20130430-1.mkv

comment:7 by Samuel, 2 years ago

Resolution: invalid
Status: closedreopened

comment:8 by Elon Musk, 2 years ago

Resolution: invalid
Status: reopenedclosed

This file is already supported.

comment:9 by Carl Eugen Hoyos, 2 years ago

Component: avformatundetermined
Keywords: hdv removed

I believe a better explanation is that you have to provide a use case: This is typically not necessary if you provide a multimedia file that is not supported by FFmpeg but can be played with another player but it is needed for unclear feature requests such as yours. The use case should not be a Wikipedia link or some random specification but should contain an explanation what you wanted to achieve and why, what you tried and what didn’t work.

comment:10 by Samuel, 2 years ago

Resolution: invalid
Status: closedreopened

Ok i see.

The PS3 doesn't support HD H.264 and is very picky on the 720p and FFmpeg tickets show that muxing or transcoding output are not reliably accepted by the PS3, so MPEG-2 is sadly the best supported format.

So to keep the HD definition a convertion to MPEG-2 is prefered, and HDV-HD is know to be well supported AFAIK.

Last edited 2 years ago by Samuel (previous) (diff)

comment:11 by Elon Musk, 2 years ago

Resolution: invalid
Status: reopenedclosed

Unclear request. MPEG-2 is supported.

comment:12 by Samuel, 2 years ago

As i said in precedent explaination attempt, that is to avoid to have to set the bufsize, maxrate and others video settings.
Like FFmpeg already do for other formats as DVDs for exemple.

comment:13 by Carl Eugen Hoyos, 2 years ago

Am I correct that this is the first time you mention the PS3?

Please provide a file that is supported by the PS3 and has the properties you like.

in reply to:  9 comment:14 by Carl Eugen Hoyos, 2 years ago

Replying to cehoyos:

I believe a better explanation is that you have to provide a use case

I realize that this was a little unclear: This is of course not about a use case but about your use case that you are able to test and reproduce.

in reply to:  10 comment:15 by Carl Eugen Hoyos, 2 years ago

Replying to Sami32:

The PS3 doesn't support HD H.264

Not related to this ticket, this page seems to disagree:
https://manuals.playstation.net/document/en/ps3/current/video/filetypes.html
It's mentioned elsewhere that 1080@30 is supposed to play.

comment:16 by Samuel, 2 years ago

We all know the official specifications and discovered some of their limitations or omission over time, like it support AC-3 but not the one produced by FFmpeg.
https://trac.ffmpeg.org/ticket/2162
Nothing best than real tests ;-)

Not related to this ticket, these pages seem disagree:
https://trac.ffmpeg.org/ticket/2515

As well as hundred of forum threads since many years, that probly explain why media server are streaming MPEG-2 to the PS3 ;-)

comment:17 by Samuel, 2 years ago

Yes, i never mentioned PS3 before because i didn't see the need, so if was wrong i apology for that.

Last edited 2 years ago by Samuel (previous) (diff)

comment:18 by Samuel, 2 years ago

@Richard Yes, but encoding MPEG-2 HD with ffmpeg show plenty of overflow warning# messages in the log, like the mpeg format was only done for SD. Changing the bufsize and maxrate didn't fixed it.

Note: See TracTickets for help on using tickets.