Opened 3 years ago

Closed 2 years ago

#8069 closed defect (fixed)

FFmpeg vp8 decoder produces decoded contents with color artfiacts

Reported by: Hirokazu Honda Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: vp8 regression
Cc: hiroh@chromium.org Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I find the decoded result by ffmpeg vp8 decoder is different from vpxdec.
The video frames decoded by ffmpeg has color artifacts, whereas ones decoded by vpxdec doesn't.
There seems to be issues in ffmpeg vp8 decoder.
I will attach one video file to be reproduced, and md5 results of both ffmpeg and vpxdec.

Attachments (3)

ffmpeg.frames.md5 (36.0 KB ) - added by Hirokazu Honda 3 years ago.
md5 result of ffmpeg got by ffmpeg -i simple_dump.webm -f framemd5 ffmpeg.frames.md5
vpxdec.frames.md5 (36.0 KB ) - added by Hirokazu Honda 3 years ago.
md5 result of vpxdec got by vpxdec simple_dump.webm --md5 -o output_w%w_h%h_%2.frame --i420 >vpxdec.frames.md5
simple_dump_cut.webm (2.4 MB ) - added by Carl Eugen Hoyos 3 years ago.

Change History (10)

by Hirokazu Honda, 3 years ago

Attachment: ffmpeg.frames.md5 added

md5 result of ffmpeg got by ffmpeg -i simple_dump.webm -f framemd5 ffmpeg.frames.md5

by Hirokazu Honda, 3 years ago

Attachment: vpxdec.frames.md5 added

md5 result of vpxdec got by vpxdec simple_dump.webm --md5 -o output_w%w_h%h_%2.frame --i420 >vpxdec.frames.md5

comment:1 by Hirokazu Honda, 3 years ago

The video file is available in this link
I cannot have uploaded here as it is larger than the file size limitation (2.5MB).
The video file size is 12.0 MB.

comment:2 by Carl Eugen Hoyos, 3 years ago

Component: ffmpegavcodec
Keywords: regression added
Priority: normalimportant
Reproduced by developer: set

by Carl Eugen Hoyos, 3 years ago

Attachment: simple_dump_cut.webm added

comment:3 by Hirokazu Honda, 3 years ago

Is there any update about this issue?

This seems an important issue as ffmpeg vp8 decoder produces a different video frame from libvpx vp8 decoder.

in reply to:  2 ; comment:4 by Michael Niedermayer, 3 years ago

Replying to cehoyos:

Regression since 1afd246960202917e244c844c534e9c1e3c323f5

Will fix the regression but the md5 does not match libvpx before this commit either

in reply to:  4 comment:5 by Carl Eugen Hoyos, 3 years ago

Replying to michael:

Replying to cehoyos:

Regression since 1afd246960202917e244c844c534e9c1e3c323f5

Will fix the regression but the md5 does not match libvpx before this commit either

That is an imo unrelated change since 9f6d48d696d679de77e8cb513d5f64cd708ed86f, that commit was related to tickets #4119 and #1578.

comment:6 by Hirokazu Honda, 3 years ago

Cc: hiroh@chromium.org added

comment:7 by Carl Eugen Hoyos, 2 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.