Opened 4 months ago

Closed 4 months ago

#8051 closed enhancement (fixed)

Add Meridian Lossless Packing (Dolby TRUEHD) support for MP4

Reported by: likeadoc Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: mov thd
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It seems that packaging a TRUEHD/MLP stream into a mp4 container isn't supported by any currently available software - despite the capabilities of the MP4 container.

References:
http://mp4ra.org/#/codecs - see codec mlpa - (clearly states support for Dolby MLP)
https://developer.dolby.com/globalassets/technology/dolby-truehd/dolbytruehdbitstreamswithintheisobasemediafileformat.pdf - describes the storage of Dolby® TrueHD (MLP) audio bitstreams in a file format compliant with the ISO base media file format
https://en.wikipedia.org/wiki/Comparison_of_video_container_formats - see audio coding formats support - also clearly states support for TRUEHD in mp4.

Change History (6)

comment:1 Changed 4 months ago by cehoyos

  • Component changed from ffmpeg to avformat
  • Keywords mov thd added; MLP TrueHD mp4 removed
  • Priority changed from normal to wish
  • Version changed from unspecified to git-master

comment:2 follow-up: Changed 4 months ago by jamrial

Is there a sample available anywhere?

comment:4 in reply to: ↑ 2 Changed 4 months ago by Balling

Replying to jamrial:

Is there a sample available anywhere?

Are you kidding me? Any torrent film with Truehd. Really https://katcr.co/katsearch/page/1/Truehd

For example, https://katcr.co/torrent/3076173/how-to-train-your-dragon-the-hidden-world-2019-2160p-uhd-bluray-x265-10bit-hdr-truehd-7-1-atmos-deflate.html

And there is already version with Dolby Vision or/and (!) HDR10+(!) or DTS X inside. And we still do not support decoding atmos ((

comment:5 Changed 4 months ago by jamrial

  • Status changed from new to open

I didn't ask for a TrueHD sample because i wanted to look at the audio stream. I asked for a TrueHD-in-mp4 sample, as described in the spec quoted by likeadoc, to look at how it was multiplexed.

comment:6 Changed 4 months ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Implemented by James in 808a6717e0c584738c60a109afd6d47f4973d619
Please report back if you are able to test with Dolby-certified software.

Note: See TracTickets for help on using tickets.