Opened 2 years ago

Closed 2 years ago

#7964 closed defect (duplicate)

Compile error

Reported by: Jim Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Compilation fails with gmake (make doesn't work on my system, but I've built it this way on this system as recently as March). It gets about 15 minutes in before the Error:

. . .
CC	libavcodec/ptx.o
CC	libavcodec/qcelpdec.o
HOSTCC	libavcodec/qdm2_tablegen.o
In file included from libavcodec/qdm2_tablegen.c:24:
In file included from libavcodec/tableprint_vlc.h:43:
libavcodec/bitstream.c:231:17: warning: implicit declaration of function 'avpriv_request_sample' is
      invalid in C99 [-Wimplicit-function-declaration]
                avpriv_request_sample(NULL, "strange codes");
                ^
1 warning generated.
HOSTLD	libavcodec/qdm2_tablegen
libavcodec/qdm2_tablegen.o: In function `build_table':
qdm2_tablegen.c:(.text+0x1b7e): undefined reference to `avpriv_request_sample'
clang: error: linker command failed with exit code 1 (use -v to see invocation)
gmake: *** [ffbuild/common.mak:155: libavcodec/qdm2_tablegen] Error 1

How to reproduce:

[root@ffmpeg /usr/local/build/ffmpeg]# ./configure --cc=/usr/bin/clang \
--pkg-config-flags="--static" --enable-static --disable-shared \
--enable-nonfree --enable-gpl --enable-version3 \
--enable-hardcoded-tables --enable-libfdk-aac --enable-libx264 \
--enable-libx265 --enable-avfilter --enable-filters \
--disable-outdevs --disable-network --enable-libfreetype \
--enable-libfontconfig --enable-libfribidi
install prefix            /usr/local
source path               .
C compiler                /usr/bin/clang
C library                 
ARCH                      x86 (generic)
big-endian                no
runtime cpu detection     yes
standalone assembly       yes
x86 assembler             nasm
MMX enabled               yes
MMXEXT enabled            yes
3DNow! enabled            yes
3DNow! extended enabled   yes
SSE enabled               yes
SSSE3 enabled             yes
AESNI enabled             yes
AVX enabled               yes
AVX2 enabled              yes
AVX-512 enabled           yes
XOP enabled               yes
FMA3 enabled              yes
FMA4 enabled              yes
i686 features enabled     yes
CMOV is fast              yes
EBX available             yes
EBP available             yes
debug symbols             yes
strip symbols             yes
optimize for size         no
optimizations             yes
static                    yes
shared                    no
postprocessing support    yes
network support           no
threading support         pthreads
safe bitstream reader     yes
texi2html enabled         no
perl enabled              yes
pod2man enabled           yes
makeinfo enabled          no
makeinfo supports HTML    no
. . . 
[root@ffmpeg /usr/local/build/ffmpeg]# gmake

ffmpeg version
Can't find a version but just git-cloned it this morning

Change History (1)

comment:1 by Carl Eugen Hoyos, 2 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #7962

Note: See TracTickets for help on using tickets.