Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#7826 closed defect (duplicate)

fails to correctly read Opus test vector files

Reported by: calestyo Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

The Opus developer provide a set of test vector files to test for certain stuff of Opus:
https://people.xiph.org/~greg/opus_testvectors/
especially:
correctness_gain_loud_speech.opus
correctness_gain_silent_output.opus
correctness_trimming_nobeeps.opus

ffmpeg seems to incorrectly read correctness_trimming_nobeeps.opus, namely, there are beeps at the start and end of the file which (listen to the file) should not be played/used/etc. by conforming programs.

ffmpeg however only "ignores" the final beep and not both, as a conforming program should.

How to reproduce:

$ ffmpeg -i correctness_trimming_nobeeps.opus correctness_trimming_nobeeps.wav

$ #playback the resulting WAV with any player will result in the leading beep to be heared.

$ ffmpeg -version
ffmpeg version 4.1.1-1 Copyright (c) 2000-2019 the FFmpeg developers
built with gcc 8 (Debian 8.2.0-20)
configuration: --prefix=/usr --extra-version=1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared
libavutil      56. 22.100 / 56. 22.100
libavcodec     58. 35.100 / 58. 35.100
libavformat    58. 20.100 / 58. 20.100
libavdevice    58.  5.100 / 58.  5.100
libavfilter     7. 40.101 /  7. 40.101
libavresample   4.  0.  0 /  4.  0.  0
libswscale      5.  3.100 /  5.  3.100
libswresample   3.  3.100 /  3.  3.100
libpostproc    55.  3.100 / 55.  3.100

Change History (4)

comment:1 Changed 6 months ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 6 months ago by calestyo

uhm?

comment:3 Changed 6 months ago by mkver

  1. This is a duplicate of #5258.
  2. #5258 has actually already been fixed, but the fix happened after the release of release 4.1. Notice that only current git head is supported here, hence your ticket is invalid.

comment:4 Changed 6 months ago by calestyo

  • Resolution changed from invalid to duplicate

In fact you're right, and I've just verified this on a (standard, i.e. no furhter ./configure options) build of master.

Note: See TracTickets for help on using tickets.