Opened 6 months ago

Closed 5 months ago

#7805 closed defect (invalid)

[hls] new in-stream twitch ads confuses ffmpeg

Reported by: sylware Owned by:
Priority: normal Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg -i "$(youtube-dl -f best "https://www.twitch.tv/any_twitch_streamer_with_ads")" -map 0 -f mpegts -c copy pipe:1 </dev/null | mplayer -

I remux in mpeg-ts because I did not see a way to output the concatened ts files from the hls demuxer. That said, I think the pb is to tell the mpeg-ts muxer to get a whole hls segment, I may be severely wrong though.

Attachments (1)

log (107.0 KB) - added by sylware 6 months ago.
sane console output (no confusion from ffmpeg)

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 months ago by cehoyos

Please provide a simplified command line including the complete, uncut console output to make this a valid ticket.

Changed 6 months ago by sylware

sane console output (no confusion from ffmpeg)

comment:2 Changed 6 months ago by sylware

The minimal command line is in the initial ticket comment.

The log in attachment is with some ads running at the start of the stream, which does _not_ confuse ffmpeg. ffmpeg is getting confused when some ads run in the middle of the stream, that I cannot reproduce when I want for obvious reasons.

comment:3 Changed 6 months ago by stevenliu

liuqideMBP:su liuqi$ youtube-dl -f best "https://www.twitch.tv/any_twitch_streamer_with_ads"
[twitch:stream] any_twitch_streamer_with_ads: Downloading stream JSON
ERROR: any_twitch_streamer_with_ads is offline

comment:4 Changed 6 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

comment:5 Changed 6 months ago by sylware

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

comment:6 Changed 6 months ago by sylware

twitch in-stream ads were ok on dreamleague live broadcast... may have been an issue on twitch side. Testing more to confirm.

comment:7 Changed 5 months ago by sylware

  • Resolution set to invalid
  • Status changed from reopened to closed

twitch(amazon) did stop including in-stream ads. closing till they do it again.

Note: See TracTickets for help on using tickets.