Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#7742 closed defect (fixed)

Enabling the option --enable-cuda-sdk results in a build failure. Failing component is scale_cuda

Reported by: Brainiarc7 Owned by:
Priority: important Component: avfilter
Version: git-master Keywords: cuda regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

As stated, enabling the option --enable-cuda-sdk results in a build error, as shown below.

How to reproduce:

Having installed all dependencies, including the nv-codec-headers, results in:

In file included from libavfilter/vf_scale_cuda.c:31:0:
./libavutil/cuda_check.h: In function ‘ff_cuda_check’:
./libavutil/cuda_check.h:38:7: error: ‘tcuGetErrorName’ undeclared (first use in this function); did you mean ‘cuGetErrorName’?
     ((tcuGetErrorName *)cuGetErrorName_fn)(err, &err_name);
       ^~~~~~~~~~~~~~~
       cuGetErrorName
./libavutil/cuda_check.h:38:7: note: each undeclared identifier is reported only once for each function it appears in
./libavutil/cuda_check.h:38:24: error: expected expression before ‘)’ token
     ((tcuGetErrorName *)cuGetErrorName_fn)(err, &err_name);
                        ^
./libavutil/cuda_check.h:39:7: error: ‘tcuGetErrorString’ undeclared (first use in this function); did you mean ‘cuGetErrorString’?
     ((tcuGetErrorString *)cuGetErrorString_fn)(err, &err_string);
       ^~~~~~~~~~~~~~~~~
       cuGetErrorString
./libavutil/cuda_check.h:39:26: error: expected expression before ‘)’ token
     ((tcuGetErrorString *)cuGetErrorString_fn)(err, &err_string);
                          ^
ffbuild/common.mak:60: recipe for target 'libavfilter/vf_scale_cuda.o' failed
make: *** [libavfilter/vf_scale_cuda.o] Error 1
make: *** Waiting for unfinished jobs....

Build configuration:

FFmpeg is configured and built as shown:

cd ~/ffmpeg_sources
git clone https://github.com/FFmpeg/FFmpeg -b master
cd FFmpeg
PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig:/opt/intel/mediasdk/lib/pkgconfig" ./configure \
    --pkg-config-flags=--static \
    --prefix=/home/brainiarc7/bin \
    --bindir=/home/brainiarc7/bin \
    --extra-cflags=-I/home/brainiarc7/bin/include \
    --extra-ldflags=-L/home/brainiarc7/bin/lib \
    --enable-cuda-sdk \
    --enable-cuvid \
    --enable-libnpp \
    --extra-cflags=-I/usr/local/cuda/include/ \
    --extra-ldflags=-L/usr/local/cuda/lib64/ \
    --enable-nvenc \
    --extra-cflags=-I/opt/intel/mediasdk/include \
    --extra-ldflags=-L/opt/intel/mediasdk/lib \
    --extra-ldflags=-L/opt/intel/mediasdk/plugins \
    --enable-libmfx \
    --enable-libass \
    --enable-vaapi \
    --disable-debug \
    --enable-libdrm \
    --enable-opencl \
    --enable-gpl \
    --cpu=native \
    --enable-opengl \
    --enable-libfdk-aac \
    --enable-libx265 \
    --extra-libs='-lpthread -lm' \
    --enable-nonfree
PATH="$HOME/bin:$PATH" make -j$(nproc) VERBOSE=1
make -j$(nproc) install
make -j$(nproc) distclean
hash -r

Build logs are attached below.

Attachments (1)

config.log (524.6 KB) - added by Brainiarc7 3 months ago.
config.log

Download all attachments as: .zip

Change History (5)

Changed 3 months ago by Brainiarc7

config.log

comment:1 Changed 3 months ago by cehoyos

  • Component changed from build system to avfilter
  • Keywords cuda regression added; scale_cuda removed
  • Priority changed from normal to important

comment:2 Changed 3 months ago by bermond

A git bisect shows that this is caused by commit 15c6390.

comment:3 Changed 3 months ago by philipl

  • Resolution set to fixed
  • Status changed from new to closed
Last edited 3 months ago by cehoyos (previous) (diff)

comment:4 Changed 3 months ago by cehoyos

The commit message should mention the ticket number.

Note: See TracTickets for help on using tickets.