Opened 4 months ago

Closed 2 months ago

#7659 closed enhancement (invalid)

feature request vp8_qsv and vp9_qsv encoders

Reported by: Tupsi Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: qsv
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The ffmpeg wiki lists https://trac.ffmpeg.org/wiki/Hardware/QuickSync
the later intel cpus as being able to encode vp8 and vp9 in hardware. It would be nice, if ffmpeg supports this by adding respective vp8_qsv and vp9_qsv encoders.

Change History (7)

comment:1 Changed 4 months ago by Ewout

A few months ago Intel updated their MediaSDK with VP9 hardware encode: https://github.com/Intel-Media-SDK/MediaSDK/tree/master/_studio/vp9e_hw

A few other people are also looking into it: https://github.com/Intel-Media-SDK/MediaSDK/issues/1005

On Linux using hardware acceleration is already possible using the vp8_vaapi and vp9_vaapi encoders using the VAAPI (Video Acceleration API).

Last edited 4 months ago by Ewout (previous) (diff)

comment:2 Changed 4 months ago by cehoyos

  • Keywords vp8 vp9 removed

comment:3 Changed 4 months ago by cehoyos

  • Priority changed from normal to wish

comment:4 Changed 2 months ago by lizhong1008

VP8 encoding is not supported by MSDK, see https://github.com/Intel-Media-SDK/MediaSDK/issues/947
VP9 encoding is supported by MSDK, but only available on Intel IceLake? platform which hasn't been released. I will add it once IceLake? is launched.

comment:5 follow-up: Changed 2 months ago by lizhong1008

BTW, vp8 and vp9 encoding can be supported by FFmpeg-vaapi, probably you can have a try, but you need to take care of which driver can be supported on your HW platform. What is your prefer HW platform?

comment:6 in reply to: ↑ 5 ; follow-up: Changed 2 months ago by Tupsi

Hmm, seems I misread something then, because I was under the impression when I wrote my initial post, that my new Coffe Lake-S (i9600k) is able to encode in vp9, but maybe I got that confused with my GPU where AMD claims vp9 is possible, but ffmpeg is missing support for that as well (but I realise this here is the wrong place to ask for it as this has to be in _amf and not _qsv).

Replying to lizhong1008:

BTW, vp8 and vp9 encoding can be supported by FFmpeg-vaapi, probably you can have a try, but you need to take care of which driver can be supported on your HW platform. What is your prefer HW platform?

comment:7 in reply to: ↑ 6 Changed 2 months ago by lizhong1008

  • Resolution set to invalid
  • Status changed from new to closed

Replying to Tupsi:

Hmm, seems I misread something then, because I was under the impression when I wrote my initial post, that my new Coffe Lake-S (i9600k) is able to encode in vp9, but maybe I got that confused with my GPU where AMD claims vp9 is possible, but ffmpeg is missing support for that as well (but I realise this here is the wrong place to ask for it as this has to be in _amf and not _qsv).

Ok, Let me to close this ticket. You can create a new one for amf encoders if you would like.

Note: See TracTickets for help on using tickets.