Opened 4 years ago

Closed 3 years ago

#7612 closed defect (fixed)

Crash of FFMPEG webp decoder

Reported by: Alexandre Vrubel Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: webp crash abort regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
When opening some WEBP files, the multithreaded webp decoder causes a crash on Windows version of ffmpeg, and explicitly asks for a bug report. linux version crashes as well.

How to reproduce:
ffmpeg -i crash_reading.webp output.jpg

ffmpeg version built on 20181201

The log and source image that causes the bug are added to this ticket.

I managed to circumvent the bug using the "-threads 1" option. Therefore, it appears that the bug is caused by a multithreading issue inside the webp decoder

Attachments (2)

ffmpeg-20181212-143540.log (6.9 KB ) - added by Alexandre Vrubel 4 years ago.
ffmpeg log of the bug
crash_reading.webp (4.0 KB ) - added by Alexandre Vrubel 4 years ago.
source image file that always reproduces the bug

Download all attachments as: .zip

Change History (6)

by Alexandre Vrubel, 4 years ago

Attachment: ffmpeg-20181212-143540.log added

ffmpeg log of the bug

by Alexandre Vrubel, 4 years ago

Attachment: crash_reading.webp added

source image file that always reproduces the bug

comment:1 by Carl Eugen Hoyos, 4 years ago

Keywords: crash abort added
Priority: normalimportant
Reproduced by developer: set
Status: newopen
Version: unspecifiedgit-master

comment:2 by Carl Eugen Hoyos, 4 years ago

Keywords: regression added

The crash is apparently a regression since bddb2343 / 061a0c14, decoding was broken since b26ccf218d933660c551832b4b14976b2acb3f0c

Last edited 3 years ago by Carl Eugen Hoyos (previous) (diff)

comment:3 by Carl Eugen Hoyos, 3 years ago

An analysis of the issue by James Zern is in ticket #8107.

comment:4 by Carl Eugen Hoyos, 3 years ago

Resolution: fixed
Status: openclosed

Fixed by Pascal Massimino in 857fd2ad99032e3ff51363975997d0caf0e72e7b

Note: See TracTickets for help on using tickets.