Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#7606 closed defect (invalid)

ffmpeg 4.0.2 and above missing 'ffio_open_dyn_packet_buf' from avformat.lib & avformat.dll

Reported by: dinesh.gupta01 Owned by:
Priority: normal Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

While building 'ffmpeg' 4.0.2 and above, missing function 'ffio_open_dyn_packet_buf'. Due to this I am unable to compile my project. I spend my whole week to find the solution but didn't get success. When searching this function in code than it is available on source code.But when build from sorce code this function is missing. Please guide me what I need to do.

./libavformat/aviobuf.c:1396:int ffio_open_dyn_packet_buf(AVIOContext s, int max_packet_size)
./libavformat/avio_internal.h:120:int ffio_open_dyn_packet_buf(AVIOContext
s, int max_packet_size);
./libavformat/movenchint.c:430: if ((ret = ffio_open_dyn_packet_buf(&rtp_ctx->pb,
./libavformat/rtpenc_chain.c:85: ret = ffio_open_dyn_packet_buf(&rtpctx->pb, packet_size);
./libavformat/rtspenc.c:158: * ffio_open_dyn_packet_buf. So by writing the interleaving header
./libavformat/rtspenc.c:178: return ffio_open_dyn_packet_buf(&rtpctx->pb, RTSP_TCP_MAX_PACKET_SIZE);

I have below environment:
OS : Windows 10
MSVC : Visual Studio 15 with Windows SDK 10.0.17763.0
MSYS2 : MINGW32_NT-10.0-WOW

Getting below error:

server-ffmpeg.obj : error LNK2019: unresolved external symbol _ffio_open_dyn_packet_buf referenced in function "int cdecl ff_server_send_packet_1(char const *,void *,int,struct AVPacket *,int64,struct timeval *)" (?ff_server_send_packet_1@@YAHPBDPAXHPAUAVPacket@@_JPAUtimeval@@@Z)

rtspserver.obj : error LNK2019: unresolved external symbol _ff_rtsp_parse_line referenced in function "void * cdecl rtspserver(void *)" (?rtspserver@@YAPAXPAX@Z)
server-ffmpeg.dll : fatal error LNK1120: 1 unresolved externals

Please guild me to achieve above result.

Thanks

Change History (3)

comment:1 Changed 7 months ago by cehoyos

  • Keywords ffio_open_dyn_packet_buf removed
  • Resolution set to invalid
  • Status changed from new to closed

This is an internal symbol, you are not supposed to use it outside of libavformat.

comment:2 Changed 7 months ago by dinesh.gupta01

If 'ffio_open_dyn_packet_buf' function removed, so alternative would be available. Please guide me which one should I use.

comment:3 Changed 7 months ago by cehoyos

Note that the function was not removed but since it is an internal function you are not supposed to use it (except within libavformat). Please post all library usage question on the libav-user mailing list, this is a bug tracker.

Note: See TracTickets for help on using tickets.