Opened 5 years ago

Closed 5 years ago

#7478 closed defect (invalid)

ERROR: vorbis not found using pkg-config

Reported by: Yujin Boby Owned by: Pedro Soares
Priority: normal Component: ffmpeg
Version: git-master Keywords: libvorbis
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes


Summary of the bug: ERROR: vorbis not found using pkg-config
How to reproduce:

Configure fail with the error.

git clone
cd FFmpeg
./configure --prefix=/usr --enable-shared --enable-libxvid --enable-libvorbis --enable-libtheora --enable-libmp3lame --enable-gpl --enable-libfdk-aac --enable-nonfree --enable-libx264 --enable-libfreetype

I already installed vorbis with command

cd /usr/local/src/
wget -c
tar zxvf libvorbis-1.3.6.tar.gz
cd /usr/local/src/libvorbis-1.3.6
./configure && make && make install

Attachments (1)

config.log (368.6 KB ) - added by Yujin Boby 5 years ago.

Download all attachments as: .zip

Change History (7)

by Yujin Boby, 5 years ago

Attachment: config.log added


comment:1 by Yujin Boby, 5 years ago

Sorry, i pasted my login info here, since i can't edit the issue, i changed password, ignore that part.

comment:2 by Pedro Soares, 5 years ago

Hi @serverok,

From your config.log, the issue seems to be that pkg-config did not found a vorbis
pkg on your system. Generally, the libraries come with a .pc file that indicates to
pkg-config necessary variables. This vorbis.pc file should be copied to pkg-config path
during make install. I ran your procedure and that was the case for me:

180 make[2]: Nothing to be done for 'install-exec-am'.
181 /bin/mkdir -p '/usr/local/share/aclocal'
182 /usr/bin/install -c -m 644 vorbis.m4 '/usr/local/share/aclocal'
183 /bin/mkdir -p '/usr/local/lib/pkgconfig'
184 /usr/bin/install -c -m 644 vorbis.pc vorbisenc.pc vorbisfile.pc '/usr/local/lib/pkgconfig'

Check if during your make install this procedure was executed. You could also check
with pkg-config --exists --print-errors vorbis && echo $?, if it returns 0 then vorbis
was found by pkg-config.

In anyway this doesn't seem to be a problem in ffmpeg itself.

comment:3 by Pedro Soares, 5 years ago

Analyzed by developer: set
Owner: set to Pedro Soares
Status: newopen

comment:4 by James, 5 years ago

If you installed libvorbis to /usr/local, then you should tell pkg-config to look for it there.

Try using PKG_CONFIG_PATH="/usr/local/lib/pkgconfig" as environment variable when running configure.

comment:5 by Yujin Boby, 5 years ago

I reinstalled libvorbis with prefix /usr, but

pkg-config --exists --print-errors vorbis

Failed. Same for x264. One i set

export PKG_CONFIG_PATH="/usr/lib/pkgconfig"

It worked.

comment:6 by James, 5 years ago

Resolution: invalid
Status: openclosed
Note: See TracTickets for help on using tickets.