Opened 4 months ago

Closed 4 months ago

#7348 closed defect (invalid)

configure fails in MSYS2 with deprecation warning in Texinfo/Parser.pm for ffnvcodec

Reported by: LigH Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

Building ffmpeg in MSYS2 / MinGW32 with GCC 8.2.0 and Perl 5.28.0-1, the configure step fails for ffnvcodec: Texinfo/Parser?.pm complains about a deprecated "unescaped left brace in regex".

How to reproduce:

I let the media-autobuild_suite compile ffmpeg, which updates MSYS2 before updating all used libraries to their last revisions (except for cases where a specific revision is required due to bugs).

An archive of log files is attached to this report. The last error messages displayed are:

┌ ffmpeg git ........................................ [Recently updated]
├ Changing options to comply to nonfree...
├ Compiling static FFmpeg...
├ Running configure...
Likely error:
../configure --prefix=/local32 --bindir=/local32/bin-video --pkg-config-flags=--static --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --disable-debug --enable-ffnvcodec --enable-nvdec --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwavpack --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libaom --enable-version3 --enable-chromaprint --enable-decklink --enable-frei0r --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libfdk-aac --enable-libflite --enable-libfribidi --enable-libgme --enable-libgsm --enable-libilbc --enable-libkvazaar --enable-libmodplug --enable-libopenh264 --enable-libopenmpt --enable-librtmp --enable-librubberband --enable-libssh --enable-libtesseract --enable-libxavs --enable-libzmq --enable-libzvbi --enable-opencl --enable-opengl --enable-libcodec2 --enable-libsrt --enable-ladspa --enable-openssl --extra-cflags=-fopenmp --extra-libs=-lgomp --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DLIBSSH_STATIC --extra-ldflags=-Wl,--allow-multiple-definition --extra-cflags=-DCACA_STATIC --extra-cflags=-DMODPLUG_STATIC --extra-cflags=-DCHROMAPRINT_NODLL --extra-libs=-lstdc++ --extra-cflags=-DZMQ_STATIC --extra-libs=-lpsapi --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv --disable-w32threads --extra-cflags=-DKVZ_STATIC_LIB --enable-nonfree
Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.32), passed through in regex; marked by <-- HERE in m/^\s+@([[:alnum:]][[:alnum:]\-]*)({ <-- HERE })?\s*/ at /usr/share/texinfo/Texinfo/Parser.pm line 5481.
Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.32), passed through in regex; marked by <-- HERE in m/^\s+@([[:alnum:]][[:alnum:]\-]*)({ <-- HERE })?\s*(\@(c|comment)((\@|\s+).*)?)?/ at /usr/share/texinfo/Texinfo/Parser.pm line 5485.
ERROR: cuda requested, but not all dependencies are satisfied: ffnvcodec

Attachments (1)

logs.zip (135.8 KB) - added by LigH 4 months ago.
Archived log files from compilation in media-autobuild_suite

Download all attachments as: .zip

Change History (4)

Changed 4 months ago by LigH

Archived log files from compilation in media-autobuild_suite

comment:1 Changed 4 months ago by heleppkes

Those warnings are unrelated. It fails because you requested CUDA features but the required headers are not available.

Please note that we cannot and will not debug issues with third party build scripts.

PS:
The warning is actually from /usr/share/texinfo/Texinfo/Parser.pm, a file local to your system.

Last edited 4 months ago by heleppkes (previous) (diff)

comment:2 Changed 4 months ago by LigH

OK, so these warnings were misleading for me, sorry...

I will correct my report in the issue for the suite, and this ticket can possibly be closed.

Last edited 4 months ago by LigH (previous) (diff)

comment:3 Changed 4 months ago by cehoyos

  • Component changed from build system to undetermined
  • Keywords configure cuda ffnvcodec texinfo regex perl removed
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.