Opened 4 months ago

Closed 4 months ago

#7253 closed defect (needs_more_info)

webp: Multiple ff_thread_finish_setup()

Reported by: michael.heuberger Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Using ffmpeg v4 build g3a56ade1f on 20180610 for Linux 64 I'm seeing multiple warnings like these polluting my log

[webp @ 0x4d68740] Multiple ff_thread_finish_setup() calls

Known issue?

Change History (3)

comment:1 Changed 4 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

comment:2 Changed 4 months ago by michael.heuberger

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

right, here more info. the command, without sensible data, was

$ ffmpeg -f image2 -thread_queue_size 3072 -framerate 15.2 -i /(removed)/%d.webp -i /(removed)/stretched.wav -y -ac 1 -acodec aac -vcodec libx264 -filter:v drawtext=fontfile=/(removed)/Varela-Regular.ttf:text=www.videomail.io:fontsize=14:fontcolor=0xFFFFFF@0.6:x=text_h/1.5:y=main_h-(text_h*2):shadowcolor=0x111111@0.6:shadowx=1:shadowy=1,scale=trunc(iw/2)*2:trunc(ih/2)*2 -crf 17 -pix_fmt yuv420p -preset medium -profile:v baseline -level:v 3.1 -movflags +faststart /(removed)/videomail_good.mp4 -acodec libvorbis -vcodec libvpx -filter:v drawtext=fontfile=/(removed)/Varela-Regular.ttf:text=www.videomail.io:fontsize=14:fontcolor=0xFFFFFF@0.6:x=text_h/1.5:y=main_h-(text_h*2):shadowcolor=0x111111@0.6:shadowx=1:shadowy=1,scale=trunc(iw/2)*2:trunc(ih/2)*2 -crf 7 -pix_fmt yuv420p -deadline good -cpu-used 1 -loglevel warning /(removed)/videomail_good.webm

and here the ffmpeg version with the libraries

$./ffmpeg
ffmpeg version N-45896-g19c3df0cd-static https://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 6.3.0 (Debian 6.3.0-18+deb9u1) 20170516
  configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc-6 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg
  libavutil      56. 17.100 / 56. 17.100
  libavcodec     58. 19.100 / 58. 19.100
  libavformat    58. 13.100 / 58. 13.100
  libavdevice    58.  4.100 / 58.  4.100
  libavfilter     7. 20.100 /  7. 20.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

hope this helps?

comment:3 Changed 4 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from reopened to closed

Please reopen this ticket if the issue is reproducible with current FFmpeg git head and if you can provide an actual working command line together with its complete, uncut console output.

Note: See TracTickets for help on using tickets.