Opened 5 years ago

Closed 5 years ago

#717 closed defect (fixed)

AVFrame->format field not set when decoding audio

Reported by: Markus Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes


According to header documentation, the AVFrame format field should contain a value of type "enum AVSampleFormat" for audio data, but it is always -1 when calling avcodec_decode_audio4 (verified only for mpeg audio, but a quick code look up makes be belief this is true for all other decoders as well).

Since this value is present in the AVCodecContext field "sample_fmt", it would be easy to just copy it from there to the decoded AVFrame, just as this already happens for avcodec_decode_video2 (where pix_fmt is copied there).

Change History (1)

comment:1 Changed 5 years ago by saste

  • Analyzed by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed since commit 8a4a5f6ff756fdba44254015c714f173b2db6f64, which was merged in commit 484e59a0a0329c4005ddacd05051925345f4362f, committed on 26 December 2011.

Please re-open in case it is not yet working for you.

Note: See TracTickets for help on using tickets.