Opened 5 years ago

Closed 3 years ago

#7139 closed task (invalid)

ffprobe xsd misses some attributes

Reported by: Denis Kokorin Owned by:
Priority: normal Component: ffprobe
Version: unspecified Keywords: xsd
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: ffprobe XSD misses some attributes of side_data element.

<side_data_list>
	<side_data side_data_type="Display Matrix" displaymatrix="
00000000:            0       65536           0
00000001:       -65536           0           0
00000002:            0           0  1073741824
" rotation="-90"/>
</side_data_list>

Attributes displaymatrix and rotation are absent in ffprobe.xsd.

How to reproduce:
Get video recorded with Android or iPhone (may be other devices) and check it with ffprobe.

% ffprobe.exe -bitexact -print_format xml=x=1:q=1 -noprivate -show_data -show_streams .\VID_20180317_232636.mp4

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (1)

ffprobe_output.txt (4.8 KB ) - added by Denis Kokorin 5 years ago.
output

Download all attachments as: .zip

Change History (4)

by Denis Kokorin, 5 years ago

Attachment: ffprobe_output.txt added

output

comment:1 by Carl Eugen Hoyos, 5 years ago

Pleas test current FFmpeg git head to make this a valid ticket and please provide a short sample file.

comment:2 by Denis Kokorin, 5 years ago

The problem is not in code, but in XSD. Here is related issue https://trac.ffmpeg.org/ticket/515.

comment:3 by Elon Musk, 3 years ago

Resolution: invalid
Status: newclosed

Invalid ticket, missing input file.

Note: See TracTickets for help on using tickets.