Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7137 closed defect (invalid)

bitstream filter dump_extra does not work with -vcodec copy

Reported by: leeoxiang Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords: h264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Summary of the bug:

i want to send my h264 encoded file to another rtp system, the rtp system need sps and pps before every keyframe

How to reproduce:

% ffmpeg -re -fflags nobuffer -i ./guigu_1.mp4 -vcodec copy  -an -bsf:v dump_extra=freq=keyframe -f rtp -payload_type 96 rtp://

does not generate  per gop  sps and pps 

ffmpeg -re -fflags nobuffer -i ./guigu_1.mp4 -vcodec libx264  -an -bsf:v dump_extra=freq=keyframe -f rtp -payload_type 96 rtp://

works fine.

ffmpeg version


Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (7)

comment:1 Changed 3 years ago by leeoxiang

A bitstream filter operates on the encoded stream data, and performs bitstream level modifications without performing decoding

as the docs said, you do not need to decod the stream todo bitstream filter. it is a bug.

comment:2 Changed 3 years ago by mkver

The H.264 track in your input file isn't in annex B format, but in mp4 format. So is the extradata. The thing is that the format of the mp4-style extradata is different from the format that is used at the mp4 sample level; in other words, the output of the dump_extra bitstream filter is a totally invalid stream. Use the h264_mp4toannexb bitstream filter before dump_extra.

Last edited 3 years ago by mkver (previous) (diff)

comment:3 Changed 3 years ago by leeoxiang

thanks it works now

comment:4 Changed 3 years ago by leeoxiang

thanks it works now

comment:5 Changed 3 years ago by leeoxiang

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 3 years ago by mkver

  • Resolution changed from fixed to invalid

comment:7 Changed 3 years ago by cehoyos

  • Version changed from 3.4 to unspecified
Note: See TracTickets for help on using tickets.