#7040 closed defect (needs_more_info)

transcode mp4 using qsv get "Error opening the internal VPP session"

Reported by: zzugyl Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: qsv
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I get a video file filmed by android phone. Try to transcode using ffmpeg with qsv to accelate video decode. But it doesnot work well.
How to reproduce:

ffmpeg.exe -v debug -hwaccel qsv -c:v h264_qsv -noautorotate -i VID_20180127_122111.mp4 -vcodec h264_qsv -f mp4 out.mp4
ffmpeg version 3.4.2 Copyright (c) 2000-2018 the FFmpeg developers

But when I use CPU mode to decode, it works well:

ffmpeg.exe -v debug -hwaccel qsv -noautorotate -i VID_20180127_122111.mp4 -vcodec h264_qsv -f mp4 out.mp4

ffmpeg.exe download from https://ffmpeg.zeranoe.com/builds/
video file can play using android video player or vlc or other video player.
I upload to https://share.weiyun.com/3cdd40d6b7d60377079a8f3692eae3cd
and https://pan.baidu.com/s/1dFXvpG9
MD5: 2EA487F5359C0600ABB8B77D41E6BA96

Attachments (1)

ffmpeg-20180224-transcode.txt (9.4 KB) - added by zzugyl 10 months ago.
ffmpeg transcode log

Download all attachments as: .zip

Change History (3)

Changed 10 months ago by zzugyl

ffmpeg transcode log

comment:1 Changed 10 months ago by lizhong1008

Can't reproduce it with master branch (commit: 40102a21374096ce0ba05c67c6e7474f176af2d0) on Linux (centos 7.3, MSS2017ESSR3). I see many qsv patches on master branch haven't been merged to ffmpeg 3.4.2. Could you try the master branch?

comment:2 Changed 10 months ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords hwaccel h264_qsv removed
  • Priority changed from important to normal
  • Resolution set to needs_more_info
  • Status changed from new to closed
  • Version changed from 3.4 to unspecified
Note: See TracTickets for help on using tickets.