Opened 2 weeks ago

Closed 2 weeks ago

Last modified 7 days ago

#6942 closed defect (duplicate)

Progress line repeats on narrow terminal windows

Reported by: forthrin Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

The progress line in FFmpeg 3.4.1 on macOS/Homebrew requires at least ~110 columns wide terminal, or else the line will be repeated and flood the terminal each time they are printed (quite annoying!)

frame= 1073 fps=106 q=28.0 size=    3840kB time=00:00:43.02 bitrate= 731.1kbits/s dup=1 drop=0 speed=4.24x  

Suggestion: Given each element a priority, so that when the window shrinks, the elements disappear intelligently one by one (1=Stays longest, 9=Goes first)

4 frame= 1073
6 fps=106
5 q=28.0
2 size= 3840kB
1 time=00:00:43.02
3 bitrate= 731.1kbits/s
8 dup=1
9 drop=0 7
7 speed=4.24x

Change History (2)

comment:1 Changed 2 weeks ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #2349 (I do not really understand how this can be relevant on osx but for small console windows it is reproducible on all systems).

comment:2 Changed 7 days ago by forthrin

It's relevant because you may keep your terminal "narrow" (~80 columns) eg. to fit a tiled desktop layout, and FFmpeg is the only terminal program that forces me to expand it to prevent this annoyance.

Note: See TracTickets for help on using tickets.