Opened 4 weeks ago

Closed 3 weeks ago

#6926 closed defect (fixed)

Compile error on Mintty/Mingw with ffbuild/common.mak & libavdevice/decklink_common.o

Reported by: EJacobs Owned by:
Priority: important Component: avformat
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: Running ffmpeg compile on Minty/mingw results in errors on make - libavdevice/decklink_common.o Error 1

How to reproduce: Run media-autobuild_suite, will fail when it gets to make for 32 bit shared ffmpeg git.

Running git update for ffmpeg...
┌ ffmpeg git ........................................... [Updates found]
├ Changing options to comply to nonfree...
├ Compiling shared FFmpeg...
├ Running configure...
├ Running make...
Likely error:
from D:/media/msys64/mingw64/x86_64-w64-mingw32/include/winscard.h:10,
from D:/media/msys64/mingw64/x86_64-w64-mingw32/include/windows.h:97,
from D:/media/msys64/mingw64/x86_64-w64-mingw32/include/winsock2.h:23,
from D:/media/build/ffmpeg-git/libavformat/os_support.h:112,
from D:/media/build/ffmpeg-git/libavformat/internal.h:28,
from D:/media/build/ffmpeg-git/libavdevice/decklink_common.cpp:25:
D:/media/msys64/mingw64/x86_64-w64-mingw32/include/propidl.h:1290:28: note: previous declaration of 'void BSTR_UserFree(ULONG*, OLECHAR**)'
void __RPC_USER BSTR_UserFree (ULONG *, BSTR *);
^~~~~~~~~~~~~
make: *** [/build/ffmpeg-git/ffbuild/common.mak:63: libavdevice/decklink_common.o] Error 1
make failed. Check D:/media/build/ffmpeg-git/build-shared-64bit/ab-suite.make.log
This is required for other packages, so this script will exit.

wiiaboo posted
That's a FFmpeg issue, open a trac issue there. I've mentioned it to the one who made the breaking commit, but a trac issue might solve it faster.

Attachments (1)

logs.zip (216.3 KB) - added by EJacobs 4 weeks ago.
media-autobuild_suite logs

Download all attachments as: .zip

Change History (5)

Changed 4 weeks ago by EJacobs

media-autobuild_suite logs

comment:1 Changed 4 weeks ago by EJacobs

  • Summary changed from Compile error on Minty/Mingw to Compile error on Minty/Mingw with ffbuild/common.mak & libavdevice/decklink_common.o

comment:2 Changed 4 weeks ago by EJacobs

  • Summary changed from Compile error on Minty/Mingw with ffbuild/common.mak & libavdevice/decklink_common.o to Compile error on Mintty/Mingw with ffbuild/common.mak & libavdevice/decklink_common.o

comment:3 Changed 3 weeks ago by cehoyos

  • Component changed from ffmpeg to avdevice
  • Keywords decklink regression added; common.mak decklink_common.o removed

Please confirm that the issue is reproducible with ./configure --enable-decklink --enable-nonfree && make (no external scripts are supported) and tell us which change introduced the regression.

comment:4 Changed 3 weeks ago by jamrial

  • Component changed from avdevice to avformat
  • Keywords decklink removed
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.