Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#6909 closed defect (wontfix)

vlc play properly,ffmpeg convert failed

Reported by: tinybug Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mov edts regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

run: ffmpeg -i 0c490b1e-3342-4b00-a33e-1ce5ae26af21.mp4 -y test.mp4
cause error: Too many packets buffered for output stream 0:1.

Attachments (1)

0c490b1e-3342-4b00-a33e-1ce5ae26af21.mp4 (2.0 MB) - added by tinybug 12 months ago.

Download all attachments as: .zip

Change History (6)

Changed 12 months ago by tinybug

comment:1 Changed 12 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mov edts regression added; convert failed removed
  • Priority changed from normal to important

comment:2 Changed 12 months ago by isasi

This video has an edit list with duration "0", which means we should play for "0" seconds, so ffmpeg won't output any video packets. This is in line with Quicktime player behavior. If you play the file with Quicktime the video won't play, just the audio.

I am guessing the conversion fails because in the encoding process, while interleaving audio and video, audio packets are queued until a video packet appears, but since the demuxer doesn't output any video packets, too many packets are buffered.

Even if conversion succeeds, the output won't have any video which is not what you want I guess. This is similar to many other bugs . Please see https://trac.ffmpeg.org/ticket/6138#comment:7 . You can use -advanced_editlist=0 (which avoids parsing edit lists) to play this file .

comment:3 Changed 12 months ago by isasi

  • Analyzed by developer set
  • Reproduced by developer set
  • Resolution set to wontfix
  • Status changed from new to closed

comment:4 Changed 12 months ago by tinybug

hello isasi, but in the video track header atom with duration "16375[00:00:27]", why not use this duration or compatible with it?

comment:5 Changed 12 months ago by tinybug

if I'm use "-ignore_editlist 1" option for input file, it convert success.

ffmpeg -ignore_editlist 1 -i 0c490b1e-3342-4b00-a33e-1ce5ae26af21.mp4 -y test.mp4

Note: See TracTickets for help on using tickets.