Opened 4 years ago

Closed 7 months ago

#6731 closed defect (fixed)

build no longer works: ERROR: libbluray not found using pkg-config

Reported by: hydra3333 Owned by:
Priority: important Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
A "standard" build had worked for months, but no longer does, now throwing error
ERROR: libbluray not found using pkg-config
config log to be attached

ffmpeg version:
built on 2017.10.14

Attachments (2)

ffmpeg_config.log (458.5 KB ) - added by hydra3333 4 years ago.
ffmpeg config log
libbluray.pc (698 bytes ) - added by hydra3333 4 years ago.
the libbluray .pc file as amended

Download all attachments as: .zip

Change History (17)

by hydra3333, 4 years ago

Attachment: ffmpeg_config.log added

ffmpeg config log

by hydra3333, 4 years ago

Attachment: libbluray.pc added

the libbluray .pc file as amended

comment:1 by hydra3333, 4 years ago

oh, cross-compiled under ubuntu as static for used on win10 x64, using a variation of rdp's build script.

comment:2 by hydra3333, 4 years ago

I see this thread https://patchwork.ffmpeg.org/patch/5540/ already seems to refer to this and related build errors, apparently newly arising from something like

"extralibs no longer being global after this merge".

comment:3 by James, 4 years ago

Component: undeterminedbuild system
Priority: normalimportant
Version: unspecifiedgit-master

libbluray's pkg-config file seems to currently be insufficient to resolve all its dependencies.

The issue has been reported there already. See https://mailman.videolan.org/pipermail/libbluray-devel/2017-October/002855.html

comment:4 by hydra3333, 4 years ago

Thank you. In the interim, it seems it (and related matters) can be addressed in part by an appropriate end-user configure, please refer here -

http://ffmpeg.org/pipermail/ffmpeg-devel/2017-October/217981.html

comment:5 by James, 4 years ago

libbluray seems to have fixed it in http://git.videolan.org/?p=libbluray.git;a=commitdiff;h=bd887f4e9d8e81f2656fe0d0494bf20af852a23c

It should be available in their next release.

comment:6 by Hunny Puppy, 4 years ago

It seems to still fail but with a different error now:

patching file configure.ac
Hunk #1 FAILED at 27.

comment:7 by James, 4 years ago

I'm not sure what you're trying to do, but the above is a commit from libbluray.

Assuming you built libbluray from source, you can recompile it from git head after fetching the above commit. Otherwise wait for them to tag a release and your distro or package manager to update to it.

comment:8 by Hunny Puppy, 4 years ago

hmm, I'm building using the ffmpeg build helpers rdp script to build it. I removed the sources and had it re-download the git and compile and I'm still seeing that error.

I believe the script is doing

git clone https://git.videolan.org/git/libbluray.git <folder>
get fetch
git checkout -f master
git merge origin/master

Anything else required?

Last edited 4 years ago by Hunny Puppy (previous) (diff)

comment:9 by James, 4 years ago

That error is something trying to patch configure.ac from libbluray. Probably the script you mention you're using.

It's unrelated to the issue at hand and you should look at it with whoever wrote the script.

comment:10 by Hunny Puppy, 4 years ago

I just nuked the whole sandbox and tried a fresh build from scratch and it worked. Looks like something was left over outside the libburay source folder which the script was trying to reference.

Thanks! It's working now.

Last edited 4 years ago by Hunny Puppy (previous) (diff)

comment:11 by Hunny Puppy, 4 years ago

I just nuked the whole sandbox and tried a fresh build from scratch and it worked. Looks like something was left over outside the libbluray source folder which the script was trying to reference.

Thanks! It's working now.

Last edited 4 years ago by Hunny Puppy (previous) (diff)

comment:12 by CoRoNe, 4 years ago

I believe this ticket is now fixed and thus can be closed.

comment:13 by James, 4 years ago

Resolution: fixed
Status: newclosed

comment:14 by Rapper_skull, 7 months ago

Resolution: fixed
Status: closedreopened

I am getting the same problem. I cloned libbluray repo and compiled it using:

./bootstrap && \
PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix "$HOME/ffmpeg_build" --bindir="$HOME/ffmpeg_build/bin" --libdir="$HOME/ffmpeg_build/lib" && \
PATH="$HOME/bin:$PATH" make && \
make install

Then I tried to compile ffmpeg with:

cd ~/ffmpeg_sources && \
wget -O ffmpeg-snapshot.tar.bz2 https://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2 && \
tar xjvf ffmpeg-snapshot.tar.bz2 && \
cd ffmpeg && \
PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure \
  --prefix="$HOME/ffmpeg_build" \
  --pkg-config-flags="--static" \
  --extra-cflags="-I$HOME/ffmpeg_build/include -I/usr/local/cuda/include" \
  --extra-ldflags="-L$HOME/ffmpeg_build/lib -L/usr/local/cuda/lib64" \
  --extra-libs="-lpthread -lm" \
  --ld="g++" \
  --bindir="$HOME/bin" \
  --enable-gpl \
  --enable-gnutls \
  --enable-libaom \
  --enable-libass \
  --enable-libfdk-aac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libopus \
  --enable-libsvtav1 \
  --enable-libdav1d \
  --enable-libvorbis \
  --enable-libvpx \
  --enable-libx264 \
  --enable-libx265 \
  --enable-nonfree \
  --enable-libbluray \
  --enable-cuda --enable-cuvid --enable-nvenc --enable-libnpp && \
PATH="$HOME/bin:$PATH" make -j$(nproc) && \
make install && \
hash -r

Unfortunately I get the following error:

ERROR: libbluray not found using pkg-config

comment:15 by Carl Eugen Hoyos, 7 months ago

Resolution: fixed
Status: reopenedclosed

Please do not reopen three-year old tickets and please ask all build questions on the user mailing list.

Note: See TracTickets for help on using tickets.