Opened 22 months ago

Closed 8 months ago

#6726 closed enhancement (fixed)

ATSC A/53 CC support missing from nvenc_h264 encoder

Reported by: unsword Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: cc nvenc
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Other H.264 encoders have ATSC A/53 CC copy from source support which was added with this commit:
https://github.com/FFmpeg/FFmpeg/commit/e06114fed3afa69187b3dfc09a7a1a25cfd558b3

However the required option -a53cc is not present for the nvenc_h264 encoder

Looks like there was a patch submitted to add A/53 to the nvenc encoder but not implemented ?
https://ffmpeg.org/pipermail/ffmpeg-devel/2016-June/194927.html

Summary of the bug:
How to reproduce:

ffmpeg -h encoder=nvenc_h264

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (3)

comment:1 Changed 21 months ago by cehoyos

  • Keywords cc nvenc added; a53 CC nvenc_h264 removed
  • Priority changed from normal to wish
  • Version changed from unspecified to git-master

Additional patches are attached to ticket #6802.

comment:2 Changed 15 months ago by Brainiarc7

Hello,

Any updates on this ticket?

comment:3 Changed 8 months ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

I believe this was implemented in 5a88e8c36581fed09c7db6dc7229f1fd9ab5559d

Note: See TracTickets for help on using tickets.