Opened 5 years ago

Closed 5 years ago

#670 closed enhancement (invalid)

Does ffmpeg support key frame alignment when creating files for multi-bitrate streaming????

Reported by: asbro Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Does ffmpeg support key frame alignment when creating files for multi-bitrate streaming????

Change History (10)

comment:1 Changed 5 years ago by cehoyos

Please explain what you are trying to achieve, how (provide command line and complete, uncut console output) and what makes you think it does not work.

comment:2 Changed 5 years ago by asbro

I didn't tried yet. I'm just asking if ffmpeg encodes one file into 2 files with diferent bitrate but key frames with exactly the same timecode values.

comment:3 Changed 5 years ago by michael

  • Resolution set to invalid
  • Status changed from new to closed

You can force a specific keyframe distance and disable scene change detection which would achive what you are asking for.
Or
you can use -force_key_frames to force them to be at specific places, like for example the same for all
your streams.

I thus think what you ask for is supported.
If not please reopen the ticket and clarify.

comment:4 Changed 5 years ago by reimar

In addition at least x264 will place the keyframes according to the first pass log file, so as long as you use the same one the keyframes will be placed identically.
If the encodes vary significantly you will probably want to run an additional pass to update the log file though (instead of only running the second pass against the existing log file) to reduce quality loss.

comment:5 Changed 5 years ago by asbro

thanks!

comment:6 Changed 5 years ago by nickg

How to generate multiple versions of the same video file at different bitrates that are properly key-frame aligned? Is it posible with ffmpeg?

Here is an article with example http://www.wowza.com/forums/content.php?192-Encoding-Suggestions-for-Video-on-Demand

The article says that "Multi-birate encoding has not worked using ffmpeg" is it right?

comment:7 Changed 5 years ago by nickg

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:8 Changed 5 years ago by cehoyos

If it does not work for you, please provide your failing command line (preferably not using external libraries like x264 and faac if the problem is also reproducible without using them) and complete, uncut console output.

If you just need user support (and do not want to report a problem), please consider sending a mail to ffmpeg-users, this tracker is for enhancement requests and bug reports.

comment:9 Changed 5 years ago by nickg

I just need to know, is it posible with ffmpeg. I have no bug report. Thanks.

comment:10 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.