Opened 4 years ago

Closed 4 months ago

#6585 closed enhancement (fixed)

Transcode audio to ADPCM for XAudio

Reported by: nkast Owned by: zane
Priority: wish Component: avcodec
Version: git-master Keywords: ADPCM
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes

Description

We are trying to trans-code audio into ADPCM format (codec: adpcm_ms) for use by XAudio (DirectX SDK).

The problem is that XAudio seems to require adpcm blocks of size 32,64,128,256 or 512. FFmpeg always generates blocks of 1024.

It would be nice if there was a parameter for adpcm_ms to set the blocksize.

Change History (3)

comment:1 Changed 3 years ago by cehoyos

  • Keywords XAudio BLOCK_SIZE removed
  • Priority changed from normal to wish
  • Version changed from unspecified to git-master

comment:2 Changed 5 months ago by zane

  • Analyzed by developer set
  • Owner set to zane
  • Status changed from new to open

comment:3 Changed 4 months ago by zane

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.