Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#652 closed enhancement (invalid)

maintain aspect ratio.

Reported by: dE_logics Owned by: michael
Priority: wish Component: swscale
Version: 0.8.6 Keywords:
Cc: de.techno@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Currently ffmpeg doesn't have a parameter to maintain the aspect ratio of the original video given a certain height/width.

If you search around in the internet, this's a high demand feature, will be very useful if implemented.

Thanks!

Change History (4)

comment:1 Changed 5 years ago by cehoyos

Failing command line and complete, uncut console output missing.

comment:2 Changed 5 years ago by dE_logics

This's a feature request, there's no output to place since this feature is missing.

comment:3 Changed 5 years ago by cehoyos

  • Keywords maintain aspect ratio height width removed
  • Resolution set to invalid
  • Status changed from new to closed

Please reopen if you can provide an easy to reproduce testcase that shows why this is a desirable feature.

comment:4 Changed 5 years ago by dE_logics

For e.g. we have a HD 1920x1080 p video which needs to be converted for a 320x280 mobile device using easy to use front ends like winff.

We need to maintain the aspect ratio in this case to ensure the video doesn't distort yet is playable in the small screen. For e.g. we wanna maintain the 320 px width and make the height variable.

Anyway, this bug should be closed cause the scale filter provides such a feature, I'll write about this in my blog.

Note: See TracTickets for help on using tickets.