Opened 5 years ago

Closed 5 years ago

#641 closed defect (fixed)

Build fails with --disable-mmx2 flag (error: implicit declaration of function 'yuv2yuvX_MMX2')

Reported by: Spekadyon Owned by:
Priority: normal Component: build system
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Running configure with --disable-mmx2, with no other options, makes the build fail with the following error:

CC      libswscale/x86/swscale_mmx.o
In file included from libswscale/x86/swscale_mmx.c:89:0:
libswscale/x86/swscale_template.c: In function 'sws_init_swScale_MMX':
libswscale/x86/swscale_template.c:1873:21: warning: unused variable 'should_dither'
libswscale/x86/swscale_template.c:1942:44: warning: assignment from incompatible pointer type
libswscale/x86/swscale_template.c:1943:44: warning: assignment from incompatible pointer type
libswscale/x86/swscale_template.c:1954:42: warning: assignment from incompatible pointer type
libswscale/x86/swscale_template.c:1955:42: warning: assignment from incompatible pointer type
libswscale/x86/swscale_mmx.c: In function 'updateMMXDitherTables':
libswscale/x86/swscale_mmx.c:131:9: warning: new qualifiers in middle of multi-level non-const cast are unsafe
libswscale/x86/swscale_mmx.c:132:9: warning: new qualifiers in middle of multi-level non-const cast are unsafe
libswscale/x86/swscale_mmx.c:133:9: warning: new qualifiers in middle of multi-level non-const cast are unsafe
libswscale/x86/swscale_mmx.c: In function 'yuv2yuvX_sse3':
libswscale/x86/swscale_mmx.c:184:9: error: implicit declaration of function 'yuv2yuvX_MMX2'
libswscale/x86/swscale_mmx.c:184:9: warning: 'return' with a value, in function returning void
libswscale/x86/swscale_mmx.c: At top level:
libswscale/x86/swscale_mmx.c:179:13: warning: 'yuv2yuvX_sse3' defined but not used
make: *** [libswscale/x86/swscale_mmx.o] Error 1
make: *** Waiting for unfinished jobs....

This does not occur with the --enable-mmx2 flag.

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Keywords regression added
  • Reproduced by developer set
  • Status changed from new to open

This is a regression since e484b64ce37e7bc7556c6113ce6f10671e20f61f.

comment:2 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.